aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/base-passwd
diff options
context:
space:
mode:
authorMark Hatle <mark.hatle@windriver.com>2011-06-20 13:03:47 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-06-23 21:01:48 +0100
commit8996d4dfd302dc966e39d752761f0f3adbc75683 (patch)
tree8880b6e6636956c8212419a4acc34e910ad20e6e /meta/recipes-core/base-passwd
parentb25deb36bdca771f892b034c1a39b99ca6e0d54c (diff)
downloadopenembedded-core-contrib-8996d4dfd302dc966e39d752761f0f3adbc75683.tar.gz
base-passwd: Fix owners/groups
Fix the owners and groups of specific files copied from the developmen tree. This resolves an issue where those files gain the user/group id of the build user. Signed-off-by: Mark Hatle <mark.hatle@windriver.com>
Diffstat (limited to 'meta/recipes-core/base-passwd')
-rw-r--r--meta/recipes-core/base-passwd/base-passwd_3.5.22.bb10
1 files changed, 5 insertions, 5 deletions
diff --git a/meta/recipes-core/base-passwd/base-passwd_3.5.22.bb b/meta/recipes-core/base-passwd/base-passwd_3.5.22.bb
index 3315c68196..7b1fdf17c2 100644
--- a/meta/recipes-core/base-passwd/base-passwd_3.5.22.bb
+++ b/meta/recipes-core/base-passwd/base-passwd_3.5.22.bb
@@ -1,7 +1,7 @@
SUMMARY = "Base system master password/group files."
DESCRIPTION = "The master copies of the user database files (/etc/passwd and /etc/group). The update-passwd tool is also provided to keep the system databases synchronized with these master files."
SECTION = "base"
-PR = "r2"
+PR = "r3"
LICENSE = "GPLv2+"
LIC_FILES_CHKSUM = "file://COPYING;md5=eb723b61539feef013de476e68b5c50a"
@@ -21,16 +21,16 @@ SSTATEPOSTINSTFUNCS += "base_passwd_sstate_postinst"
do_install () {
install -d -m 755 ${D}${sbindir}
- install -p -m 755 update-passwd ${D}${sbindir}/
+ install -o root -g root -p -m 755 update-passwd ${D}${sbindir}/
install -d -m 755 ${D}${mandir}/man8 ${D}${mandir}/pl/man8
install -p -m 644 man/update-passwd.8 ${D}${mandir}/man8/
install -p -m 644 man/update-passwd.pl.8 \
${D}${mandir}/pl/man8/update-passwd.8
gzip -9 ${D}${mandir}/man8/* ${D}${mandir}/pl/man8/*
install -d -m 755 ${D}${datadir}/base-passwd
- install -p -m 644 passwd.master ${D}${datadir}/base-passwd/
- install -p -m 644 group.master ${D}${datadir}/base-passwd/
- install -p -m 644 ${S}/../login.defs ${D}${datadir}/base-passwd/login.defs
+ install -o root -g root -p -m 644 passwd.master ${D}${datadir}/base-passwd/
+ install -o root -g root -p -m 644 group.master ${D}${datadir}/base-passwd/
+ install -o root -g root -p -m 644 ${S}/../login.defs ${D}${datadir}/base-passwd/login.defs
install -d -m 755 ${D}${docdir}/${PN}
install -p -m 644 debian/changelog ${D}${docdir}/${PN}/