aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/base-files
diff options
context:
space:
mode:
authorMark Asselstine <mark.asselstine@windriver.com>2012-09-08 08:42:21 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-09-12 14:44:52 +0100
commit5fd3503d4a438d126f44fe8118e9ea465e7699c2 (patch)
tree4cc50274dc786fdb62414969912f757b4a542edd /meta/recipes-core/base-files
parentaf9fd7566a5de4716a202922f5eabb13a412f2fb (diff)
downloadopenembedded-core-contrib-5fd3503d4a438d126f44fe8118e9ea465e7699c2.tar.gz
base-files: provide a mechanism to skip creation of the hostname file
The existence of a /etc/hostname file causes any hostname provided on the kernel command line or via dhcp to be overwritten by the initscripts 'init.d/hostname.sh'. This change allows you to set a value of "" for 'hostname' which will skip the creation of the /etc/hostname file by the base-files package. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Jason Wessel <jason.wessel@windriver.com> Signed-off-by: Mark Hatle <mark.hatle@windriver.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-core/base-files')
-rw-r--r--meta/recipes-core/base-files/base-files_3.0.14.bb14
1 files changed, 8 insertions, 6 deletions
diff --git a/meta/recipes-core/base-files/base-files_3.0.14.bb b/meta/recipes-core/base-files/base-files_3.0.14.bb
index 6bab040e4f..e80cff1790 100644
--- a/meta/recipes-core/base-files/base-files_3.0.14.bb
+++ b/meta/recipes-core/base-files/base-files_3.0.14.bb
@@ -1,7 +1,7 @@
SUMMARY = "Miscellaneous files for the base system."
DESCRIPTION = "The base-files package creates the basic system directory structure and provides a small set of key configuration files for the system."
SECTION = "base"
-PR = "r71"
+PR = "r72"
LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://licenses/GPL-2;md5=94d55d512a9ba36caa9b7df079bae19f"
# Removed all license related tasks in this recipe as license.bbclass
@@ -107,10 +107,12 @@ do_install () {
}
do_install_basefilesissue () {
- if [ -n "${MACHINE}" -a "${hostname}" = "openembedded" ]; then
- echo ${MACHINE} > ${D}${sysconfdir}/hostname
- else
- echo ${hostname} > ${D}${sysconfdir}/hostname
+ if [ "${hostname}" != "" ]; then
+ if [ -n "${MACHINE}" -a "${hostname}" = "openembedded" ]; then
+ echo ${MACHINE} > ${D}${sysconfdir}/hostname
+ else
+ echo ${hostname} > ${D}${sysconfdir}/hostname
+ fi
fi
install -m 644 ${WORKDIR}/issue* ${D}${sysconfdir}
@@ -144,5 +146,5 @@ FILES_${PN}-doc = "${docdir} ${datadir}/common-licenses"
PACKAGE_ARCH = "${MACHINE_ARCH}"
-CONFFILES_${PN} = "${sysconfdir}/fstab ${sysconfdir}/hostname"
+CONFFILES_${PN} = "${sysconfdir}/fstab ${@['', '${sysconfdir}/hostname'][(d.getVar('hostname', True) != '')]}"