aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity
diff options
context:
space:
mode:
authorPatrick Ohly <patrick.ohly@intel.com>2017-01-23 15:17:04 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-01-26 10:41:11 +0000
commita33a252462e2d7b90a1c89e42a96b9696eb08b23 (patch)
tree9fb6801498903001dc3ed68d73a215782391aae2 /meta/recipes-connectivity
parent4b43aab5b2043a5b83ef1fa9a8406f8a46ccfa72 (diff)
downloadopenembedded-core-contrib-a33a252462e2d7b90a1c89e42a96b9696eb08b23.tar.gz
socat: support native compilation
This is needed for building the swtpm TPM simulator (recipe in meta-security). Native compilation disables tcp-wrappers by default to simplify the build. "nativesdk" is added just in case that someone also wants this in an SDK. Signed-off-by: Patrick Ohly <patrick.ohly@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-connectivity')
-rw-r--r--meta/recipes-connectivity/socat/socat_1.7.3.1.bb5
1 files changed, 4 insertions, 1 deletions
diff --git a/meta/recipes-connectivity/socat/socat_1.7.3.1.bb b/meta/recipes-connectivity/socat/socat_1.7.3.1.bb
index 4da6d3970b..a579f1ef0f 100644
--- a/meta/recipes-connectivity/socat/socat_1.7.3.1.bb
+++ b/meta/recipes-connectivity/socat/socat_1.7.3.1.bb
@@ -29,10 +29,13 @@ EXTRA_OECONF += "ac_cv_have_z_modifier=yes \
ac_cv_header_bsd_libutil_h=no \
"
-PACKAGECONFIG ??= "tcp-wrappers"
+PACKAGECONFIG_class-target ??= "tcp-wrappers"
+PACKAGECONFIG ??= ""
PACKAGECONFIG[tcp-wrappers] = "--enable-libwrap,--disable-libwrap,tcp-wrappers"
do_install_prepend () {
mkdir -p ${D}${bindir}
install -d ${D}${bindir} ${D}${mandir}/man1
}
+
+BBCLASSEXTEND = "native nativesdk"