aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2015-01-12 19:08:51 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-01-16 23:06:46 +0000
commit38aa1ef57392fcb726fcdd0b708b9d76f0279c77 (patch)
tree79cf70c7d8f5d75f70ee64a9890bd2bd683c94eb /meta/recipes-connectivity
parentaea42f59c8331c4d5944f698453bfd663aa0c59d (diff)
downloadopenembedded-core-contrib-38aa1ef57392fcb726fcdd0b708b9d76f0279c77.tar.gz
connman: fix B != S
And bump the PR to avoid: configure: error: source directory already configured; run "make distclean" there first Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
Diffstat (limited to 'meta/recipes-connectivity')
-rw-r--r--meta/recipes-connectivity/connman/connman.inc14
-rw-r--r--meta/recipes-connectivity/connman/connman_1.26.bb2
2 files changed, 9 insertions, 7 deletions
diff --git a/meta/recipes-connectivity/connman/connman.inc b/meta/recipes-connectivity/connman/connman.inc
index ddabdb96f5..736b324704 100644
--- a/meta/recipes-connectivity/connman/connman.inc
+++ b/meta/recipes-connectivity/connman/connman.inc
@@ -67,18 +67,18 @@ SYSTEMD_SERVICE_${PN} = "connman.service"
SYSTEMD_SERVICE_${PN}-vpn = "connman-vpn.service"
SYSTEMD_WIRED_SETUP = "ExecStartPre=-${libdir}/connman/wired-setup"
-inherit autotools-brokensep pkgconfig systemd update-rc.d
+inherit autotools pkgconfig systemd update-rc.d
do_configure_append () {
- sed -i "s#ExecStart=#${SYSTEMD_WIRED_SETUP}\nExecStart=#" ${S}/src/connman.service
+ sed -i "s#ExecStart=#${SYSTEMD_WIRED_SETUP}\nExecStart=#" ${B}/src/connman.service
}
# This allows *everyone* to access ConnMan over DBus, without any access
# control. Really the at_console flag should work, which would mean that
# both this and the xuser patch can be dropped.
do_compile_append() {
- sed -i -e s:deny:allow:g src/connman-dbus.conf
- sed -i -e s:deny:allow:g vpn/vpn-dbus.conf
+ sed -i -e s:deny:allow:g ${S}/src/connman-dbus.conf
+ sed -i -e s:deny:allow:g ${S}/vpn/vpn-dbus.conf
}
do_install_append() {
@@ -89,9 +89,9 @@ do_install_append() {
fi
install -d ${D}${bindir}
- install -m 0755 ${S}/tools/*-test ${D}${bindir}
- if [ -e ${S}/tools/wispr ]; then
- install -m 0755 ${S}/tools/wispr ${D}${bindir}
+ install -m 0755 ${B}/tools/*-test ${D}${bindir}
+ if [ -e ${B}/tools/wispr ]; then
+ install -m 0755 ${B}/tools/wispr ${D}${bindir}
fi
install -m 0755 ${B}/client/connmanctl ${D}${bindir}
diff --git a/meta/recipes-connectivity/connman/connman_1.26.bb b/meta/recipes-connectivity/connman/connman_1.26.bb
index b93f1cd6c3..7c0c4f7863 100644
--- a/meta/recipes-connectivity/connman/connman_1.26.bb
+++ b/meta/recipes-connectivity/connman/connman_1.26.bb
@@ -9,3 +9,5 @@ SRC_URI[md5sum] = "ba05b110b7c81e5fa14e8b402ef37a9e"
SRC_URI[sha256sum] = "7184e4b6d954449ee00a30e188924b3e37a20ad2fd9a0b76a2bdd82c863dcf8a"
RRECOMMENDS_${PN} = "connman-conf"
+
+PR = "r1"