aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2014-07-08 16:35:26 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-07-10 17:37:40 +0100
commitfdb5aaabea9e32d687c055ca25506dcffbb37867 (patch)
tree78b643d45721a71151a649439c6abb5d3faac603 /meta/recipes-connectivity
parentf8abe9fe6e3c371d07711378c0fbfb4fad7eed81 (diff)
downloadopenembedded-core-contrib-fdb5aaabea9e32d687c055ca25506dcffbb37867.tar.gz
libnss-mdns: support ipv6 in lookups
It nothing can resolve the hostname as ipv4 it will also try ipv6. Ideally the mdns4_minimal should get replaced as well, but there's some handwaving on the internet stating it will slow things down if your ipv6 network is misconfigured. Since I can't verify that slowdown I've opted for the safe way and only do ipv6 lookup in the fallback entry. Signed-off-by: Koen Kooi <koen@dominion.thruhere.net> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-connectivity')
-rw-r--r--meta/recipes-connectivity/libnss-mdns/libnss-mdns_0.10.bb6
1 files changed, 3 insertions, 3 deletions
diff --git a/meta/recipes-connectivity/libnss-mdns/libnss-mdns_0.10.bb b/meta/recipes-connectivity/libnss-mdns/libnss-mdns_0.10.bb
index 5b8c700411..df7d196e31 100644
--- a/meta/recipes-connectivity/libnss-mdns/libnss-mdns_0.10.bb
+++ b/meta/recipes-connectivity/libnss-mdns/libnss-mdns_0.10.bb
@@ -26,13 +26,13 @@ DEBIANNAME_${PN} = "libnss-mdns"
RDEPENDS_${PN} = "avahi-daemon"
pkg_postinst_${PN} () {
- sed -e '/^hosts:/s/\s*\<mdns4\>//' \
- -e 's/\(^hosts:.*\)\(\<files\>\)\(.*\)\(\<dns\>\)\(.*\)/\1\2 mdns4_minimal [NOTFOUND=return]\3\4 mdns4\5/' \
+ sed -e '/^hosts:/s/\s*\<mdns\>//' \
+ -e 's/\(^hosts:.*\)\(\<files\>\)\(.*\)\(\<dns\>\)\(.*\)/\1\2 mdns4_minimal [NOTFOUND=return]\3\4 mdns\5/' \
-i $D/etc/nsswitch.conf
}
pkg_prerm_${PN} () {
- sed -e '/^hosts:/s/\s*\<mdns4\>//' \
+ sed -e '/^hosts:/s/\s*\<mdns\>//' \
-e '/^hosts:/s/\s*mdns4_minimal\s\+\[NOTFOUND=return\]//' \
-i $D/etc/nsswitch.conf
}