aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity
diff options
context:
space:
mode:
authorKai Kang <kai.kang@windriver.com>2014-03-26 18:15:57 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-03-27 15:46:32 +0000
commit6b6c24eccdb0030ecccadefe94c1c5b4387e46d1 (patch)
treed1637472547b5ceed86a08f724986599d66bb058 /meta/recipes-connectivity
parent44902f7550e490a9d4d2e2bcdf8c577329b4af75 (diff)
downloadopenembedded-core-contrib-6b6c24eccdb0030ecccadefe94c1c5b4387e46d1.tar.gz
cryptodev-linux: add recipe
Yocto kernel linux-yocto uses cryptodev-linux to use device /dev/crypto. So add cryptodev-linux which is one alternative of ocf-linux and then remove ocf-linux later. Signed-off-by: Kai Kang <kai.kang@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-connectivity')
-rw-r--r--meta/recipes-connectivity/openssl/cryptodev-linux_1.6.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta/recipes-connectivity/openssl/cryptodev-linux_1.6.bb b/meta/recipes-connectivity/openssl/cryptodev-linux_1.6.bb
new file mode 100644
index 0000000000..320716d6aa
--- /dev/null
+++ b/meta/recipes-connectivity/openssl/cryptodev-linux_1.6.bb
@@ -0,0 +1,22 @@
+SUMMARY = "A /dev/crypto device driver"
+HOMEPAGE = "http://cryptodev-linux.org/"
+
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
+
+SRC_URI = "http://download.gna.org/cryptodev-linux/${BPN}-${PV}.tar.gz"
+
+SRC_URI[md5sum] = "eade38998313c25fd7934719cdf8a2ea"
+SRC_URI[sha256sum] = "75f1425c8ea1f8cae523905a5a046a35092327a6152800b0b86efc4e56fb3e2f"
+
+do_compile() {
+ :
+}
+
+# Just install cryptodev.h which is the only header file needed to be exported
+do_install() {
+ install -D ${S}/crypto/cryptodev.h ${D}${includedir}/crypto/cryptodev.h
+}
+
+ALLOW_EMPTY_${PN} = "1"
+BBCLASSEXTEND = "native nativesdk"