aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity/socat/socat_1.7.3.0.bb
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2015-04-07 04:24:27 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-04-07 17:32:03 +0100
commit1c09d06ab8694612e1bd5cc63ad660d1e1ea4d64 (patch)
treedb1b6c4f26eeb4fe3291f09cb383c0c8ca8404ef /meta/recipes-connectivity/socat/socat_1.7.3.0.bb
parentbd24517116455492abbc429196e5c9db4c1be1c7 (diff)
downloadopenembedded-core-contrib-1c09d06ab8694612e1bd5cc63ad660d1e1ea4d64.tar.gz
socat: 1.7.2.4 -> 1.7.3.0
Removed fix-cross-compiling-failed.patch and socat-1.7.2.4-linux-3.17.patch since upstream has fixed them. Updated README's LIC_FILES_CHKSUM, there is a word changed (GPL -> GPLv2, it should be GPLv2 as COPYING shows), its license is already "GPL-2.0+-with-OpenSSL-exception", so we just update the md5 is OK. Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-connectivity/socat/socat_1.7.3.0.bb')
-rw-r--r--meta/recipes-connectivity/socat/socat_1.7.3.0.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/meta/recipes-connectivity/socat/socat_1.7.3.0.bb b/meta/recipes-connectivity/socat/socat_1.7.3.0.bb
new file mode 100644
index 0000000000..8923f41d8c
--- /dev/null
+++ b/meta/recipes-connectivity/socat/socat_1.7.3.0.bb
@@ -0,0 +1,37 @@
+SUMMARY = "Multipurpose relay for bidirectional data transfer"
+DESCRIPTION = "Socat is a relay for bidirectional data \
+transfer between two independent data channels."
+HOMEPAGE = "http://www.dest-unreach.org/socat/"
+
+SECTION = "console/network"
+
+DEPENDS = "openssl readline"
+
+LICENSE = "GPL-2.0+-with-OpenSSL-exception"
+LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
+ file://README;beginline=257;endline=287;md5=338c05eadd013872abb1d6e198e10a3f"
+
+
+SRC_URI = "http://www.dest-unreach.org/socat/download/socat-${PV}.tar.bz2 \
+"
+
+SRC_URI[md5sum] = "b607edb65bc6c57f4a43f06247504274"
+SRC_URI[sha256sum] = "0767e850c0329b9fdf711c6cd468565cbbb28786ba1a8a1cbd5531d4016b3e04"
+
+inherit autotools
+
+EXTRA_AUTORECONF += "--exclude=autoheader"
+
+EXTRA_OECONF += "ac_cv_have_z_modifier=yes sc_cv_sys_crdly_shift=9 \
+ sc_cv_sys_tabdly_shift=11 sc_cv_sys_csize_shift=4 \
+ ac_cv_ispeed_offset=13 \
+ ac_cv_header_bsd_libutil_h=no \
+"
+
+PACKAGECONFIG ??= "tcp-wrappers"
+PACKAGECONFIG[tcp-wrappers] = "--enable-libwrap,--disable-libwrap,tcp-wrappers"
+
+do_install_prepend () {
+ mkdir -p ${D}${bindir}
+ install -d ${D}${bindir} ${D}${mandir}/man1
+}