aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity/openssl
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2015-11-11 15:14:07 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-11-25 07:48:26 +0000
commita960b6024f1b17994b0f4683a4e70fd2a079bd90 (patch)
tree8b9b80282a5097a2384df5f13ab9728485fb9f9f /meta/recipes-connectivity/openssl
parent2f9a2fbc46aa435a0a7f7662bb62029ac714f25a (diff)
downloadopenembedded-core-contrib-a960b6024f1b17994b0f4683a4e70fd2a079bd90.tar.gz
openssl: use subdir= instead of moving files in do_configure_prepend()
For clarity and correctness of source archiving, don't move find.pl from WORKDIR to S in do_configure_prepend but tell the fetcher to put it in the right place when unpacking. Also re-order the files in SRC_URI so that patches are grouped together. Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-connectivity/openssl')
-rw-r--r--meta/recipes-connectivity/openssl/openssl_1.0.2d.bb10
1 files changed, 3 insertions, 7 deletions
diff --git a/meta/recipes-connectivity/openssl/openssl_1.0.2d.bb b/meta/recipes-connectivity/openssl/openssl_1.0.2d.bb
index 659e0bd49e..8e8d05fb41 100644
--- a/meta/recipes-connectivity/openssl/openssl_1.0.2d.bb
+++ b/meta/recipes-connectivity/openssl/openssl_1.0.2d.bb
@@ -11,7 +11,9 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=f9a8f968107345e0b75aa8c2ecaa7ec8"
export DIRS = "crypto ssl apps engines"
export OE_LDFLAGS="${LDFLAGS}"
-SRC_URI += "file://configure-targets.patch \
+SRC_URI += "file://find.pl;subdir=${BP}/util/ \
+ file://run-ptest \
+ file://configure-targets.patch \
file://shared-libs.patch \
file://oe-ldflags.patch \
file://engines-install-in-libdir-ssl.patch \
@@ -29,11 +31,9 @@ SRC_URI += "file://configure-targets.patch \
file://openssl_fix_for_x32.patch \
file://fix-cipher-des-ede3-cfb1.patch \
file://openssl-avoid-NULL-pointer-dereference-in-EVP_DigestInit_ex.patch \
- file://find.pl \
file://openssl-fix-des.pod-error.patch \
file://Makefiles-ptest.patch \
file://ptest-deps.patch \
- file://run-ptest \
file://crypto_use_bigint_in_x86-64_perl.patch \
file://openssl-1.0.2a-x32-asm.patch \
file://ptest_makefile_deps.patch \
@@ -53,10 +53,6 @@ FILES_${PN}-engines-dbg = "${libdir}/ssl/engines/.debug"
PARALLEL_MAKE = ""
PARALLEL_MAKEINST = ""
-do_configure_prepend() {
- cp ${WORKDIR}/find.pl ${S}/util/find.pl
-}
-
# The crypto_use_bigint patch means that perl's bignum module needs to be
# installed, but some distributions (for example Fedora 23) don't ship it by
# default. As the resulting error is very misleading check for bignum before