aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity/openssh
diff options
context:
space:
mode:
authorKai Kang <kai.kang@windriver.com>2015-10-27 18:00:18 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-11-16 11:39:32 +0000
commit73284790cdd46221e776859aab5e69fe36c16bee (patch)
tree3740d6705cf9e448117130d5ce6c97ece0a9b42b /meta/recipes-connectivity/openssh
parentadeb82075dd8f8c9740f1b057df364942184edc7 (diff)
downloadopenembedded-core-contrib-73284790cdd46221e776859aab5e69fe36c16bee.tar.gz
openssh: enable X11Forwarding if distro feature x11 is set
When distro feature x11 is set, it is better enable X11Forwarding for ssh daemon. For contrast, dropbear enable X11 forward by default. It does NOT need to modify ${WORKDIR}/sshd_config, so drop the modification. (From OE-Core rev: 0dc68d745f97753fc9fde896f6ee1943c1e071b3) Signed-off-by: Kai Kang <kai.kang@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-connectivity/openssh')
-rw-r--r--meta/recipes-connectivity/openssh/openssh_7.1p1.bb6
1 files changed, 5 insertions, 1 deletions
diff --git a/meta/recipes-connectivity/openssh/openssh_7.1p1.bb b/meta/recipes-connectivity/openssh/openssh_7.1p1.bb
index 40938cc08c..d81127cdcd 100644
--- a/meta/recipes-connectivity/openssh/openssh_7.1p1.bb
+++ b/meta/recipes-connectivity/openssh/openssh_7.1p1.bb
@@ -88,7 +88,11 @@ do_compile_ptest() {
do_install_append () {
if [ "${@bb.utils.contains('DISTRO_FEATURES', 'pam', 'pam', '', d)}" = "pam" ]; then
install -D -m 0644 ${WORKDIR}/sshd ${D}${sysconfdir}/pam.d/sshd
- sed -i -e 's:#UsePAM no:UsePAM yes:' ${WORKDIR}/sshd_config ${D}${sysconfdir}/ssh/sshd_config
+ sed -i -e 's:#UsePAM no:UsePAM yes:' ${D}${sysconfdir}/ssh/sshd_config
+ fi
+
+ if [ "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11', '', d)}" = "x11" ]; then
+ sed -i -e 's:#X11Forwarding no:X11Forwarding yes:' ${D}${sysconfdir}/ssh/sshd_config
fi
install -d ${D}${sysconfdir}/init.d