aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity/openssh/openssh_6.5p1.bb
diff options
context:
space:
mode:
authorMaxin B. John <maxin.john@enea.com>2014-04-24 18:00:22 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-04-25 17:10:58 +0100
commit4d0ecccae671bffb40c870a6e33d20be869b89bc (patch)
tree0d21feddbd2aaa0e8c3fec68bd8c3cce51cee800 /meta/recipes-connectivity/openssh/openssh_6.5p1.bb
parentc27e1c8961e438f2c354ce3cd7682eaf98231776 (diff)
downloadopenembedded-core-contrib-4d0ecccae671bffb40c870a6e33d20be869b89bc.tar.gz
openssh: enable ptest support
Install openssh test-suite and run it as ptest. Signed-off-by: Maxin B. John <maxin.john@enea.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-connectivity/openssh/openssh_6.5p1.bb')
-rw-r--r--meta/recipes-connectivity/openssh/openssh_6.5p1.bb12
1 files changed, 10 insertions, 2 deletions
diff --git a/meta/recipes-connectivity/openssh/openssh_6.5p1.bb b/meta/recipes-connectivity/openssh/openssh_6.5p1.bb
index d19cc5a6b2..3b10164a41 100644
--- a/meta/recipes-connectivity/openssh/openssh_6.5p1.bb
+++ b/meta/recipes-connectivity/openssh/openssh_6.5p1.bb
@@ -27,7 +27,9 @@ SRC_URI = "ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/openssh-${PV}.tar.
file://sshd.socket \
file://sshd@.service \
file://sshdgenkeys.service \
- file://volatiles.99_sshd "
+ file://volatiles.99_sshd \
+ file://add-test-support-for-busybox.patch \
+ file://run-ptest"
PAM_SRC_URI = "file://sshd"
@@ -48,7 +50,7 @@ SYSTEMD_SERVICE_${PN}-sshd = "sshd.socket"
PACKAGECONFIG ??= "tcp-wrappers"
PACKAGECONFIG[tcp-wrappers] = "--with-tcp-wrappers,,tcp-wrappers"
-inherit autotools-brokensep
+inherit autotools-brokensep ptest
# LFS support:
CFLAGS += "-D__FILE_OFFSET_BITS=64"
@@ -118,6 +120,11 @@ do_install_append () {
${D}${systemd_unitdir}/system/sshd.socket ${D}${systemd_unitdir}/system/*.service
}
+do_install_ptest () {
+ sed -i -e "s|^SFTPSERVER=.*|SFTPSERVER=${libdir}/${PN}/sftp-server|" regress/test-exec.sh
+ cp -r regress ${D}${PTEST_PATH}
+}
+
ALLOW_EMPTY_${PN} = "1"
PACKAGES =+ "${PN}-keygen ${PN}-scp ${PN}-ssh ${PN}-sshd ${PN}-sftp ${PN}-misc ${PN}-sftp-server"
@@ -132,6 +139,7 @@ FILES_${PN}-keygen = "${bindir}/ssh-keygen"
RDEPENDS_${PN} += "${PN}-scp ${PN}-ssh ${PN}-sshd ${PN}-keygen"
RDEPENDS_${PN}-sshd += "${PN}-keygen ${@base_contains('DISTRO_FEATURES', 'pam', 'pam-plugin-keyinit pam-plugin-loginuid', '', d)}"
+RDEPENDS_${PN}-ptest += "${PN}-sftp ${PN}-misc ${PN}-sftp-server make"
CONFFILES_${PN}-sshd = "${sysconfdir}/ssh/sshd_config"
CONFFILES_${PN}-ssh = "${sysconfdir}/ssh/ssh_config"