aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity/nfs-utils/nfs-utils_1.2.3.bb
diff options
context:
space:
mode:
authorQing He <qing.he@intel.com>2010-11-09 16:08:02 +0800
committerSaul Wold <sgw@linux.intel.com>2010-11-14 16:50:19 -0800
commitefa037b655d9d6f7ae45e019b2eb26763aa0f202 (patch)
tree932f355c5e0f0ba46b5650c904d361c6533e3679 /meta/recipes-connectivity/nfs-utils/nfs-utils_1.2.3.bb
parent8c898918cefa57afa08f273b48d9204275a464d1 (diff)
downloadopenembedded-core-contrib-efa037b655d9d6f7ae45e019b2eb26763aa0f202.tar.gz
nfs-utils: upgrade to version 1.2.3
from 1.2.2 Signed-off-by: Qing He <qing.he@intel.com>
Diffstat (limited to 'meta/recipes-connectivity/nfs-utils/nfs-utils_1.2.3.bb')
-rw-r--r--meta/recipes-connectivity/nfs-utils/nfs-utils_1.2.3.bb53
1 files changed, 53 insertions, 0 deletions
diff --git a/meta/recipes-connectivity/nfs-utils/nfs-utils_1.2.3.bb b/meta/recipes-connectivity/nfs-utils/nfs-utils_1.2.3.bb
new file mode 100644
index 0000000000..4056dda65c
--- /dev/null
+++ b/meta/recipes-connectivity/nfs-utils/nfs-utils_1.2.3.bb
@@ -0,0 +1,53 @@
+SUMMARY = "userspace utilities for kernel nfs"
+DESCRIPTION = "The nfs-utils package provides a daemon for the kernel \
+NFS server and related tools."
+HOMEPAGE = "http://nfs.sourceforge.net/"
+SECTION = "console/network"
+PRIORITY = "optional"
+
+LICENSE = "GPLv2+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3"
+
+# util-linux for libblkid
+DEPENDS = "libcap libnfsidmap libevent util-linux tcp-wrappers"
+RDEPENDS = "portmap"
+RRECOMMENDS = "kernel-module-nfsd"
+
+PR = "r0"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/nfs/nfs-utils-${PV}.tar.bz2 \
+ file://nfs-utils-1.0.6-uclibc.patch \
+ file://nfsserver"
+
+PARALLEL_MAKE = ""
+
+# Only kernel-module-nfsd is required here (but can be built-in) - the nfsd module will
+# pull in the remainder of the dependencies.
+
+INITSCRIPT_NAME = "nfsserver"
+# The server has no dependencies at the user run levels, so just put
+# it in at the default levels. It must be terminated before the network
+# in the shutdown levels, but that works fine.
+INITSCRIPT_PARAMS = "defaults"
+
+inherit autotools update-rc.d
+
+# --enable-uuid is need for cross-compiling
+EXTRA_OECONF = "--with-statduser=nobody \
+ --enable-nfsv41 \
+ --enable-uuid \
+ --disable-gss \
+ --disable-tirpc \
+ --with-statedir=/var/lib/nfs"
+
+INHIBIT_AUTO_STAGE = "1"
+
+do_install_append () {
+ install -d ${D}${sysconfdir}/init.d
+ install -m 0755 ${WORKDIR}/nfsserver ${D}${sysconfdir}/init.d/nfsserver
+
+ # the following are built by CC_FOR_BUILD
+ rm -f ${D}${sbindir}/rpcdebug
+ rm -f ${D}${sbindir}/rpcgen
+ rm -f ${D}${sbindir}/locktest
+}