aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity/dhcp/dhcp-4.2.3-P2/fix-client-path.patch
diff options
context:
space:
mode:
authorAndrei Gherzan <andrei@gherzan.ro>2012-02-07 21:52:33 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-02-23 23:59:15 +0000
commit1cd882c47865a501d5401bad44e1c7f460ce2699 (patch)
tree2fd92df30ac4854711bf108b4e764301c25b8f53 /meta/recipes-connectivity/dhcp/dhcp-4.2.3-P2/fix-client-path.patch
parentba175bdfe85d701298d28e5190e55207420a24e8 (diff)
downloadopenembedded-core-contrib-1cd882c47865a501d5401bad44e1c7f460ce2699.tar.gz
dhcp: Update to 4.2.3-P2
1. Update to 4.2.3-P2 2. From 4.2.0 final release, -lcrypto check was removed and we compile static libraries from bind that are linked to libcrypto. This is why i added a patch in order to add -lcrypto to LIBS. 3. Add openssl in DEPENDS as we need libcrypto from this package 4. Drop installing /var/lib/dhcp/ as it is handled in pkg_postinst Signed-off-by: Andrei Gherzan <andrei@gherzan.ro>
Diffstat (limited to 'meta/recipes-connectivity/dhcp/dhcp-4.2.3-P2/fix-client-path.patch')
-rw-r--r--meta/recipes-connectivity/dhcp/dhcp-4.2.3-P2/fix-client-path.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta/recipes-connectivity/dhcp/dhcp-4.2.3-P2/fix-client-path.patch b/meta/recipes-connectivity/dhcp/dhcp-4.2.3-P2/fix-client-path.patch
new file mode 100644
index 0000000000..97ed0d9322
--- /dev/null
+++ b/meta/recipes-connectivity/dhcp/dhcp-4.2.3-P2/fix-client-path.patch
@@ -0,0 +1,23 @@
+CLIENT_PATH is the only environment when executing dhclient-script,
+without this patch, dhclient-script won't run properly because it
+invokes ifconfig and route
+
+Upstream-Status: Inappropriate [configuration]
+
+7/28/2010 - qhe
+
+diff -ru dhcp-4.1.1-P1.orig//client/Makefile.am dhcp-4.1.1-P1/client/Makefile.am
+--- dhcp-4.1.1-P1.orig//client/Makefile.am 2010-07-29 13:20:05.000000000 +0800
++++ dhcp-4.1.1-P1/client/Makefile.am 2010-07-29 13:28:14.000000000 +0800
+@@ -10,9 +10,9 @@
+ EXTRA_DIST = $(man_MANS)
+
+ dhclient.o: dhclient.c
+- $(COMPILE) -DCLIENT_PATH='"$(sbindir)"' \
++ $(COMPILE) -DCLIENT_PATH='"PATH=$(sbindir):$(base_sbindir):$(bindir):$(base_bindir)"' \
+ -DLOCALSTATEDIR='"$(localstatedir)"' -c dhclient.c
+
+ dhc6.o: dhc6.c
+- $(COMPILE) -DCLIENT_PATH='"$(sbindir)"' \
++ $(COMPILE) -DCLIENT_PATH='"PATH=$(sbindir):$(base_sbindir):$(bindir):$(base_bindir)"' \
+ -DLOCALSTATEDIR='"$(localstatedir)"' -c dhc6.c