aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity/bluez/bluez4_4.101.bb
diff options
context:
space:
mode:
authorCristian Iorga <cristian.iorga@intel.com>2012-07-04 14:34:00 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-07-05 14:08:56 +0100
commit1b2f6a21dde6045c4604ca5463e6c4db3499ee06 (patch)
tree2c579e8286def058480a13a58527c4709c6374c5 /meta/recipes-connectivity/bluez/bluez4_4.101.bb
parent80f05ff2afed7ef24d17209d39a17cf8139855bb (diff)
downloadopenembedded-core-contrib-1b2f6a21dde6045c4604ca5463e6c4db3499ee06.tar.gz
bluez4: update to ver. 4.101
Signed-off-by: Cristian Iorga <cristian.iorga@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-connectivity/bluez/bluez4_4.101.bb')
-rw-r--r--meta/recipes-connectivity/bluez/bluez4_4.101.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/meta/recipes-connectivity/bluez/bluez4_4.101.bb b/meta/recipes-connectivity/bluez/bluez4_4.101.bb
new file mode 100644
index 0000000000..a2ba66f05b
--- /dev/null
+++ b/meta/recipes-connectivity/bluez/bluez4_4.101.bb
@@ -0,0 +1,35 @@
+require bluez4.inc
+
+PR = "r0"
+
+SRC_URI += "file://bluetooth.conf \
+ file://sbc_mmx.patch"
+
+SRC_URI[md5sum] = "fb42cb7038c380eb0e2fa208987c96ad"
+SRC_URI[sha256sum] = "59738410ade9f0e61a13c0f77d9aaffaafe49ba9418107e4ad75fe52846f7487"
+
+do_install_append() {
+ install -m 0644 ${S}/audio/audio.conf ${D}/${sysconfdir}/bluetooth/
+ install -m 0644 ${S}/network/network.conf ${D}/${sysconfdir}/bluetooth/
+ install -m 0644 ${S}/input/input.conf ${D}/${sysconfdir}/bluetooth/
+ # at_console doesn't really work with the current state of OE, so punch some more holes so people can actually use BT
+ install -m 0644 ${WORKDIR}/bluetooth.conf ${D}/${sysconfdir}/dbus-1/system.d/
+}
+
+RDEPENDS_${PN}-dev = "bluez-hcidump"
+
+ALLOW_EMPTY_libasound-module-bluez = "1"
+PACKAGES =+ "libasound-module-bluez"
+
+FILES_libasound-module-bluez = "${libdir}/alsa-lib/lib*.so ${datadir}/alsa"
+FILES_${PN} += "${libdir}/bluetooth/plugins ${libdir}/bluetooth/plugins/*.so ${base_libdir}/udev/ ${systemd_unitdir}/"
+FILES_${PN}-dev += "\
+ ${libdir}/bluetooth/plugins/*.la \
+ ${libdir}/alsa-lib/*.la \
+"
+
+FILES_${PN}-dbg += "\
+ ${libdir}/bluetooth/plugins/.debug \
+ ${libdir}/*/.debug \
+ ${base_libdir}/udev/.debug \
+ "