summaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp
diff options
context:
space:
mode:
authorLuca Boccassi <luca.boccassi@microsoft.com>2019-03-21 19:49:04 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-03-25 11:51:36 +0000
commitc99255d688a2578f1391a34915942210cf069d64 (patch)
tree8b791e76038db62e4f82ac836e1c950937d47829 /meta/recipes-bsp
parent3a4213f014fc4aa5be05dfc0722d87e01e5ff10c (diff)
downloadopenembedded-core-contrib-c99255d688a2578f1391a34915942210cf069d64.tar.gz
u-boot: install dumpimage and fit_check_sign in u-boot-tools
Dumpimage and fit_check_sign can be used to extract kernel and ramdisk from a FIT file, verify them and kexec for a faster reboot. Signed-off-by: Luca Boccassi <luca.boccassi@microsoft.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-bsp')
-rw-r--r--meta/recipes-bsp/u-boot/u-boot-tools_2019.01.bb10
1 files changed, 9 insertions, 1 deletions
diff --git a/meta/recipes-bsp/u-boot/u-boot-tools_2019.01.bb b/meta/recipes-bsp/u-boot/u-boot-tools_2019.01.bb
index ff26e32482..bede984ef7 100644
--- a/meta/recipes-bsp/u-boot/u-boot-tools_2019.01.bb
+++ b/meta/recipes-bsp/u-boot/u-boot-tools_2019.01.bb
@@ -45,11 +45,19 @@ do_install () {
# mkenvimage
install -m 0755 tools/mkenvimage ${D}${bindir}/uboot-mkenvimage
ln -sf uboot-mkenvimage ${D}${bindir}/mkenvimage
+
+ # dumpimage
+ install -m 0755 tools/dumpimage ${D}${bindir}/uboot-dumpimage
+ ln -sf uboot-dumpimage ${D}${bindir}/dumpimage
+
+ # fit_check_sign
+ install -m 0755 tools/fit_check_sign ${D}${bindir}/uboot-fit_check_sign
+ ln -sf uboot-fit_check_sign ${D}${bindir}/fit_check_sign
}
ALLOW_EMPTY_${PN} = "1"
FILES_${PN} = ""
-FILES_${PN}-mkimage = "${bindir}/uboot-mkimage ${bindir}/mkimage"
+FILES_${PN}-mkimage = "${bindir}/uboot-mkimage ${bindir}/mkimage ${bindir}/uboot-dumpimage ${bindir}/dumpimage ${bindir}/uboot-fit_check_sign ${bindir}/fit_check_sign"
FILES_${PN}-mkenvimage = "${bindir}/uboot-mkenvimage ${bindir}/mkenvimage"
RDEPENDS_${PN}-mkimage += "dtc"