summaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2019-07-01 12:25:19 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-07-02 08:10:42 +0100
commitf61e0676aabba9e006c32f0e53c69426368cd4f0 (patch)
tree8ee5f518bc48ed9982445215422324eabfe18c18 /meta/recipes-bsp
parent147c7e02fd300efe5f8c0115d127be98348c531f (diff)
downloadopenembedded-core-contrib-f61e0676aabba9e006c32f0e53c69426368cd4f0.tar.gz
efivar: ensure that target security flags are not used to build native code
Also set LDFLAGS=BUILD_LDFLAGS when compiling makeguids to ensure that any target compiler flags are not passed to the native compiler. [ YOCTO #13423 ] Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-bsp')
-rw-r--r--meta/recipes-bsp/efivar/efivar_37.bb5
1 files changed, 4 insertions, 1 deletions
diff --git a/meta/recipes-bsp/efivar/efivar_37.bb b/meta/recipes-bsp/efivar/efivar_37.bb
index c4254c70d9..9b95721a4e 100644
--- a/meta/recipes-bsp/efivar/efivar_37.bb
+++ b/meta/recipes-bsp/efivar/efivar_37.bb
@@ -23,7 +23,10 @@ LDFLAGS += "-fuse-ld=bfd"
do_compile_prepend() {
# Remove when https://github.com/rhboot/efivar/issues/130 is fixed
- oe_runmake CFLAGS="${BUILD_CFLAGS}" -C src makeguids
+ oe_runmake \
+ CFLAGS="${BUILD_CFLAGS}" \
+ LDFLAGS="${BUILD_LDFLAGS}" \
+ -C src makeguids
}
do_install() {