summaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp
diff options
context:
space:
mode:
authorMing Liu <liu.ming50@gmail.com>2019-08-04 21:03:06 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-08-06 11:23:36 +0100
commitf03ab9b21c2aeeae0bd020ee94ec9bb1d903500d (patch)
tree6c496578f8210e92b641525c37c38aa0a75c6bd9 /meta/recipes-bsp
parent39f5a3030a97bdf567ee11091dd4e95ef04585d7 (diff)
downloadopenembedded-core-contrib-f03ab9b21c2aeeae0bd020ee94ec9bb1d903500d.tar.gz
opensbi: handle deploy task under sstate
Inherit deploy bbclass and install files to DEPLOYDIR rather than in DEPLOY_DIR_IMAGE. Signed-off-by: Ming Liu <liu.ming50@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-bsp')
-rw-r--r--meta/recipes-bsp/opensbi/opensbi_0.4.bb11
1 files changed, 5 insertions, 6 deletions
diff --git a/meta/recipes-bsp/opensbi/opensbi_0.4.bb b/meta/recipes-bsp/opensbi/opensbi_0.4.bb
index 068ae762d4..382752895c 100644
--- a/meta/recipes-bsp/opensbi/opensbi_0.4.bb
+++ b/meta/recipes-bsp/opensbi/opensbi_0.4.bb
@@ -6,7 +6,7 @@ DEPENDS += "dtc-native"
require opensbi-payloads.inc
-inherit autotools-brokensep
+inherit autotools-brokensep deploy
SRCREV = "ce228ee0919deb9957192d723eecc8aaae2697c6"
SRC_URI = "git://github.com/riscv/opensbi.git \
@@ -35,13 +35,12 @@ do_install_append() {
}
do_deploy () {
- install -d ${DEPLOY_DIR_IMAGE}
- install -m 755 ${D}/platform/${RISCV_SBI_PLAT}/firmware/fw_payload.* ${DEPLOY_DIR_IMAGE}/
- install -m 755 ${D}/platform/${RISCV_SBI_PLAT}/firmware/fw_jump.* ${DEPLOY_DIR_IMAGE}/
- install -m 755 ${D}/platform/${RISCV_SBI_PLAT}/firmware/fw_dynamic.* ${DEPLOY_DIR_IMAGE}/
+ install -m 755 ${D}/platform/${RISCV_SBI_PLAT}/firmware/fw_payload.* ${DEPLOYDIR}/
+ install -m 755 ${D}/platform/${RISCV_SBI_PLAT}/firmware/fw_jump.* ${DEPLOYDIR}/
+ install -m 755 ${D}/platform/${RISCV_SBI_PLAT}/firmware/fw_dynamic.* ${DEPLOYDIR}/
}
-addtask deploy after do_install
+addtask deploy before do_build after do_install
FILES_${PN} += "/platform/${RISCV_SBI_PLAT}/firmware/fw_jump.*"
FILES_${PN} += "/platform/${RISCV_SBI_PLAT}/firmware/fw_payload.*"