aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2017-03-11 10:37:38 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-03-11 16:08:48 +0000
commite777d6873ce9a8a80288ecbcfc86239e0ed0e2f9 (patch)
tree6eada82cebd48e0088632a93e17aa7101a173f7b /meta/recipes-bsp
parent78615e9260fb5d6569de4883521b049717fa4340 (diff)
downloadopenembedded-core-contrib-e777d6873ce9a8a80288ecbcfc86239e0ed0e2f9.tar.gz
u-boot-mkimage: Fix use of 'cc' instead of BUILD_CC
OE needs to be able to change the default compiler. If we pass in HOSTCC through the make command, it overwrites not only this setting but also the setting in tools/Makefile wrapped in ifneq ($(CROSS_BUILD_TOOLS),) which breaks the build. We therefore add a way of changing the default in the top level Makefile without interfering with the other setting. I've emailed this workaround to Masahiro Yamada for discussion. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-bsp')
-rw-r--r--meta/recipes-bsp/u-boot/files/default-gcc.patch25
-rw-r--r--meta/recipes-bsp/u-boot/u-boot-mkimage_2017.01.bb4
2 files changed, 28 insertions, 1 deletions
diff --git a/meta/recipes-bsp/u-boot/files/default-gcc.patch b/meta/recipes-bsp/u-boot/files/default-gcc.patch
new file mode 100644
index 0000000000..76d192e355
--- /dev/null
+++ b/meta/recipes-bsp/u-boot/files/default-gcc.patch
@@ -0,0 +1,25 @@
+OE needs to be able to change the default compiler. If we pass in HOSTCC
+through the make command, it overwrites not only this setting but also the
+setting in tools/Makefile wrapped in ifneq ($(CROSS_BUILD_TOOLS),) which
+breaks the build.
+
+We therefore add a way of changing the default in the top level Makefile
+without interfering with the other setting.
+
+Upstream-Status: Submitted [emailed to Masahiro Yamada for discussion]
+RP 2017/3/11
+
+Index: git/Makefile
+===================================================================
+--- git.orig/Makefile
++++ git/Makefile
+@@ -254,7 +254,8 @@ CONFIG_SHELL := $(shell if [ -x "$$BASH"
+ else if [ -x /bin/bash ]; then echo /bin/bash; \
+ else echo sh; fi ; fi)
+
+-HOSTCC = cc
++DEFAULTHOSTCC = cc
++HOSTCC = $(DEFAULTHOSTCC)
+ HOSTCXX = c++
+ HOSTCFLAGS = -Wall -Wstrict-prototypes -O2 -fomit-frame-pointer \
+ $(if $(CONFIG_TOOLS_DEBUG),-g)
diff --git a/meta/recipes-bsp/u-boot/u-boot-mkimage_2017.01.bb b/meta/recipes-bsp/u-boot/u-boot-mkimage_2017.01.bb
index c110226710..9b5772ec39 100644
--- a/meta/recipes-bsp/u-boot/u-boot-mkimage_2017.01.bb
+++ b/meta/recipes-bsp/u-boot/u-boot-mkimage_2017.01.bb
@@ -1,9 +1,11 @@
require u-boot-common_${PV}.inc
+SRC_URI += "file://default-gcc.patch"
+
SUMMARY = "U-Boot bootloader image creation tool"
DEPENDS = "openssl"
-EXTRA_OEMAKE_class-target = 'CROSS_COMPILE="${TARGET_PREFIX}" CC="${CC} ${CFLAGS} ${LDFLAGS}" STRIP=true V=1'
+EXTRA_OEMAKE_class-target = 'CROSS_COMPILE="${TARGET_PREFIX}" CC="${CC} ${CFLAGS} ${LDFLAGS}" DEFAULTHOSTCC="${BUILD_CC}" STRIP=true V=1'
EXTRA_OEMAKE_class-native = 'CC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" HOSTCC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" STRIP=true V=1'
EXTRA_OEMAKE_class-nativesdk = 'CC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" HOSTCC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" STRIP=true V=1'