aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp
diff options
context:
space:
mode:
authorAndrew Goodbody <andrew.goodbody@cambrionix.com>2016-08-31 15:05:56 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-09-03 23:45:45 +0100
commit32ba805e4ffbfcb17380ed6b5164e5b25a62f330 (patch)
tree7c6d9c697b829b3dd9df4d0f635e98d4ecdf5502 /meta/recipes-bsp
parent7e821ccd221916ae8482b9113df2de704f4a99a4 (diff)
downloadopenembedded-core-contrib-32ba805e4ffbfcb17380ed6b5164e5b25a62f330.tar.gz
Fix out of tree builds of u-boot with gold linker
Need to reference config.mk file in source tree which is no longer the current directory when using out of tree builds. Signed-off-by: Andrew Goodbody <andrew.goodbody@cambrionix.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-bsp')
-rw-r--r--meta/recipes-bsp/u-boot/u-boot.inc2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-bsp/u-boot/u-boot.inc b/meta/recipes-bsp/u-boot/u-boot.inc
index 9e19c4f70f..915da8e744 100644
--- a/meta/recipes-bsp/u-boot/u-boot.inc
+++ b/meta/recipes-bsp/u-boot/u-boot.inc
@@ -67,7 +67,7 @@ UBOOT_ENV_SYMLINK ?= "${UBOOT_ENV}-${MACHINE}.${UBOOT_ENV_SUFFIX}"
do_compile () {
if [ "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', 'ld-is-gold', '', d)}" = "ld-is-gold" ] ; then
- sed -i 's/$(CROSS_COMPILE)ld$/$(CROSS_COMPILE)ld.bfd/g' config.mk
+ sed -i 's/$(CROSS_COMPILE)ld$/$(CROSS_COMPILE)ld.bfd/g' ${S}/config.mk
fi
unset LDFLAGS