summaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp
diff options
context:
space:
mode:
authorPavel Zhukov <pavel@zhukoff.net>2023-02-22 22:33:41 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2023-02-24 13:31:41 +0000
commit3ca99403d5f320c6d7ae59b107f3b3bf183b4089 (patch)
tree1b663eda0cfe61e800d986673ccd26df6801f48c /meta/recipes-bsp
parentf3be788a55a2dde1f627aa85b08dc3ffa55d751f (diff)
downloadopenembedded-core-contrib-3ca99403d5f320c6d7ae59b107f3b3bf183b4089.tar.gz
u-boot: Map arm64 into map for u-boot dts installation
While arm64 is a valid UBOOT_ARCH (according to mkimage -A) u-boot keeps arm64 specific dts under 'arch/arm' directory. As the result the recipe tries to install arch/arm64 (if UBOOT_DTB was specified) and fails with [1]. Remapping "arm64" to "arm" to fix this issue. [1] | install: cannot stat '.../u-boot/1_2023.01-r0/build/arch/arm64/dts/u-boot.dtb': No such file or directory Signed-off-by: Pavel Zhukov <pavel@zhukoff.net> Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-bsp')
-rw-r--r--meta/recipes-bsp/u-boot/u-boot.inc4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta/recipes-bsp/u-boot/u-boot.inc b/meta/recipes-bsp/u-boot/u-boot.inc
index 4636dd733b..b3482dcef3 100644
--- a/meta/recipes-bsp/u-boot/u-boot.inc
+++ b/meta/recipes-bsp/u-boot/u-boot.inc
@@ -32,7 +32,7 @@ do_savedefconfig() {
}
do_savedefconfig[nostamp] = "1"
addtask savedefconfig after do_configure
-
+UBOOT_ARCH_DIR = "${@'arm' if d.getVar('UBOOT_ARCH').startswith('arm') else d.getVar('UBOOT_ARCH')}"
do_compile () {
if [ "${@bb.utils.filter('DISTRO_FEATURES', 'ld-is-gold', d)}" ]; then
sed -i 's/$(CROSS_COMPILE)ld$/$(CROSS_COMPILE)ld.bfd/g' ${S}/config.mk
@@ -334,7 +334,7 @@ do_deploy () {
if [ -n "${UBOOT_DTB}" ]
then
- install -m 644 ${B}/arch/${UBOOT_ARCH}/dts/${UBOOT_DTB_BINARY} ${DEPLOYDIR}/
+ install -m 644 ${B}/arch/${UBOOT_ARCH_DIR}/dts/${UBOOT_DTB_BINARY} ${DEPLOYDIR}/
fi
}