summaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp
diff options
context:
space:
mode:
authorQuentin Schulz <quentin.schulz@theobroma-systems.com>2024-03-21 18:17:07 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2024-03-23 10:16:56 +0000
commitfef517b5f978cf848b9cc40e8ce6bb2762681182 (patch)
treede1983c0e3218a56f5882e6a365d2bd4a64813a6 /meta/recipes-bsp
parentb3afb80d07d97aaa786b6921fb6f61e316201367 (diff)
downloadopenembedded-core-contrib-fef517b5f978cf848b9cc40e8ce6bb2762681182.tar.gz
u-boot: fix externalsrc not triggering do_configure on defconfig changes
externalsrc only monitors files listed in CONFIGURE_FILES environment variable to know if it should trigger a rebuild of do_configure. By default it is unset, but the defconfig from U-Boot should be listed otherwise an old defconfig may be used even though the change is technically detected by the do_compile logic later in the process. Because U-Boot recipe uses `make oldconfig` when no defconfig is passed, monitor .config for that special case. This fixes U-Boot recipes not detecting defconfig changes when devtool'ed. Reported-by: Iskander Amara <iskander.amara@theobroma-systems.com> Cc: Quentin Schulz <foss+yocto@0leil.net> Signed-off-by: Quentin Schulz <quentin.schulz@theobroma-systems.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-bsp')
-rw-r--r--meta/recipes-bsp/u-boot/u-boot-configure.inc2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta/recipes-bsp/u-boot/u-boot-configure.inc b/meta/recipes-bsp/u-boot/u-boot-configure.inc
index 235623d25a..378d675364 100644
--- a/meta/recipes-bsp/u-boot/u-boot-configure.inc
+++ b/meta/recipes-bsp/u-boot/u-boot-configure.inc
@@ -8,6 +8,8 @@ inherit uboot-config cml1
DEPENDS += "kern-tools-native"
+CONFIGURE_FILES = "${@d.getVar('UBOOT_MACHINE') or '.config'}"
+
do_configure () {
if [ -n "${UBOOT_CONFIG}" ]; then
unset i j