summaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp
diff options
context:
space:
mode:
authorAlex Kiernan <alex.kiernan@gmail.com>2022-10-07 17:46:43 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-10-25 13:42:00 +0100
commitefc54f1f836651c8ef27a683a9e5d583c8ce87a6 (patch)
tree814f755455edd695d8903998f49aeed584bc0bea /meta/recipes-bsp
parent286f91f7659307bcdf0ba541b8d6b56db5604ceb (diff)
downloadopenembedded-core-contrib-efc54f1f836651c8ef27a683a9e5d583c8ce87a6.tar.gz
u-boot: Add savedefconfig task
Add savedefconfig task which U-Boot supports (unfortunately not all consumers of cml1 support this). Signed-off-by: Alex Kiernan <alex.kiernan@gmail.com> Signed-off-by: Ross Burton <ross.burton@arm.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-bsp')
-rw-r--r--meta/recipes-bsp/u-boot/u-boot.inc7
1 files changed, 7 insertions, 0 deletions
diff --git a/meta/recipes-bsp/u-boot/u-boot.inc b/meta/recipes-bsp/u-boot/u-boot.inc
index b2f33e3826..5705e5835b 100644
--- a/meta/recipes-bsp/u-boot/u-boot.inc
+++ b/meta/recipes-bsp/u-boot/u-boot.inc
@@ -26,6 +26,13 @@ UBOOT_LOCALVERSION ?= ""
require u-boot-configure.inc
+do_savedefconfig() {
+ bbplain "Saving defconfig to:\n${B}/defconfig"
+ oe_runmake -C ${B} savedefconfig
+}
+do_savedefconfig[nostamp] = "1"
+addtask savedefconfig after do_configure
+
do_compile () {
if [ "${@bb.utils.filter('DISTRO_FEATURES', 'ld-is-gold', d)}" ]; then
sed -i 's/$(CROSS_COMPILE)ld$/$(CROSS_COMPILE)ld.bfd/g' ${S}/config.mk