summaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp
diff options
context:
space:
mode:
authorThomas Perrot <thomas.perrot@bootlin.com>2024-01-30 07:59:44 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2024-02-02 11:06:14 +0000
commitb82e1e99feb8b0d70ff4c4bcac67336d562d2e53 (patch)
tree20482bd5ac0c88dc7a1f97069f184c61af2eb9f1 /meta/recipes-bsp
parent7fa10f29b31f8aae572026a00a6354aec539d044 (diff)
downloadopenembedded-core-contrib-b82e1e99feb8b0d70ff4c4bcac67336d562d2e53.tar.gz
opensbi: append LDFLAGS to TARGET_CC_ARCH
To solve the following GNU_HASH error: ERROR: opensbi-1.4-r0 do_package_qa: QA Issue: File /share/opensbi/lp64/generic/firmware/fw_dynamic.elf in package opensbi doesn't have GNU_HASH (didn't pass LDFLAGS?) File /share/opensbi/lp64/generic/firmware/fw_payload.elf in package opensbi doesn't have GNU_HASH (didn't pass LDFLAGS?) File /share/opensbi/lp64/generic/firmware/fw_jump.elf in package opensbi doesn't have GNU_HASH (didn't pass LDFLAGS?) [ldflags] [YOCTO #15370] -- https://bugzilla.yoctoproject.org/show_bug.cgi?id=15370 Signed-off-by: Thomas Perrot <thomas.perrot@bootlin.com> Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-bsp')
-rw-r--r--meta/recipes-bsp/opensbi/opensbi_1.4.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta/recipes-bsp/opensbi/opensbi_1.4.bb b/meta/recipes-bsp/opensbi/opensbi_1.4.bb
index fd18c03cfb..cf37a41176 100644
--- a/meta/recipes-bsp/opensbi/opensbi_1.4.bb
+++ b/meta/recipes-bsp/opensbi/opensbi_1.4.bb
@@ -13,6 +13,8 @@ SRC_URI = "git://github.com/riscv/opensbi.git;branch=master;protocol=https"
S = "${WORKDIR}/git"
+TARGET_CC_ARCH += "${LDFLAGS}"
+
EXTRA_OEMAKE += "PLATFORM=${RISCV_SBI_PLAT} I=${D} FW_PIC=y CLANG_TARGET= "
# If RISCV_SBI_PAYLOAD is set then include it as a payload
EXTRA_OEMAKE:append = " ${@riscv_get_extra_oemake_image(d)}"