aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2012-09-03 14:45:38 +0100
committerSaul Wold <sgw@linux.intel.com>2012-09-03 22:52:54 -0700
commite6755e3351ccf1116c06b9608728630505908ce4 (patch)
treea3bb69e9aa55094baa3bfdd92e78c80d71cbec3f /meta/recipes-bsp
parent971fbbd50ae147805fc7498b72a046be5bffc3c7 (diff)
downloadopenembedded-core-contrib-e6755e3351ccf1116c06b9608728630505908ce4.tar.gz
qemu-config: split out anjuta-remote-run
Given that support for Anjuta is unlikely to be needed by everyone and is by no means specific to qemu, split it out to a separate recipe. The following changes were made in the process: Also depend on dbus instead of dbus-x11 since dbus-launch is now back in he main dbus package Part of the fix for [YOCTO #1690]. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-bsp')
-rw-r--r--meta/recipes-bsp/qemu-config/qemu-config.bb6
-rw-r--r--meta/recipes-bsp/qemu-config/qemu-config/anjuta-remote-run7
2 files changed, 1 insertions, 12 deletions
diff --git a/meta/recipes-bsp/qemu-config/qemu-config.bb b/meta/recipes-bsp/qemu-config/qemu-config.bb
index ac3e7f3dad..6775af34e3 100644
--- a/meta/recipes-bsp/qemu-config/qemu-config.bb
+++ b/meta/recipes-bsp/qemu-config/qemu-config.bb
@@ -10,7 +10,6 @@ COMPATIBLE_MACHINE = "(qemuarm|qemux86|qemumips|qemuppc)"
PR = "r25"
SRC_URI = "file://distcc.sh \
- file://anjuta-remote-run \
file://exports \
file://shutdown.desktop \
file://qemu-autostart"
@@ -23,9 +22,6 @@ do_install() {
install -m 0755 distcc.sh ${D}${sysconfdir}/profile.d/
install -m 0644 exports ${D}${sysconfdir}/
- install -d ${D}${bindir}
- install -m 0755 anjuta-remote-run ${D}${bindir}/
-
install -d ${D}${datadir}/applications
install -m 0644 shutdown.desktop ${D}${datadir}/applications/
@@ -38,7 +34,7 @@ pkg_postinst_${PN} () {
sed -i $D${datadir}/applications/shutdown.desktop -e 's/^Exec=halt/Exec=reboot/'
}
-RDEPENDS_${PN} = "distcc ${@base_contains('DISTRO_FEATURES', 'x11', 'dbus-x11', '', d)} packagegroup-core-nfs-server oprofileui-server rsync bash"
+RDEPENDS_${PN} = "distcc packagegroup-core-nfs-server oprofileui-server bash"
inherit update-rc.d allarch
diff --git a/meta/recipes-bsp/qemu-config/qemu-config/anjuta-remote-run b/meta/recipes-bsp/qemu-config/qemu-config/anjuta-remote-run
deleted file mode 100644
index 620e3a705b..0000000000
--- a/meta/recipes-bsp/qemu-config/qemu-config/anjuta-remote-run
+++ /dev/null
@@ -1,7 +0,0 @@
-#!/bin/sh
-
-. /etc/profile
-export DISPLAY=:0
-dbus-launch $@
-
-