aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp
diff options
context:
space:
mode:
authorMatthew McClintock <msm@freescale.com>2012-07-26 11:21:43 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-07-27 14:07:23 +0100
commit923eb657f24a1feaa93172eda8f87252e86bfea2 (patch)
treed122c378b375dfbed0e560c0fda36a44b25b1716 /meta/recipes-bsp
parentbb80a5f6f383d874b314af4263695e5a6b2d84cb (diff)
downloadopenembedded-core-contrib-923eb657f24a1feaa93172eda8f87252e86bfea2.tar.gz
u-boot.inc: update linker arguments to pass --sysroot arg
If we are building from sstate-cache it's possible to be building from another folder on another machine, therefore the linker requires that a proper --sysroot is passed too it so it can find things like libgcc.a and avoid errors such as: | arm-poky-linux-gnueabi-gcc -g -O2 -fno-common -ffixed-r8 -msoft-float -D__KERNEL__ -DCONFIG_SYS_TEXT_BASE=0x80008000 -I/local/yocto/upstream/label/ubuntu1204-64b/machine/beagleboard/poky/edison/tmp/work/beagleboard-poky-linux-gnueabi/u-boot-v2011.06+git5+b1af6f532e0d348b153d5c148369229d24af361a-r0/git/include -fno-builtin -ffreestanding -nostdinc -isystem /local/yocto/upstream/label/ubuntu1204-64b/machine/beagleboard/poky/edison/tmp/sysroots/x86_64-linux/usr/bin/armv7a-vfp-neon-poky-linux-gnueabi/../../lib/armv7a-vfp-neon-poky-linux-gnueabi/gcc/arm-poky-linux-gnueabi/4.6.3/include -pipe -DCONFIG_ARM -D__ARM__ -marm -mabi=aapcs-linux -mno-thumb-interwork -march=armv5 -Wall -Wstrict-prototypes -fno-stack-protector -fno-toplevel-reorder -o hello_world.o hello_world.c -c | arm-poky-linux-gnueabi-gcc -g -O2 -fno-common -ffixed-r8 -msoft-float -D__KERNEL__ -DCONFIG_SYS_TEXT_BASE=0x80008000 -I/local/yocto/upstream/label/ubuntu1204-64b/machine/beagleboard/poky/edison/tmp/work/beagleboard-poky-linux-gnueabi/u-boot-v2011.06+git5+b1af6f532e0d348b153d5c148369229d24af361a-r0/git/include -fno-builtin -ffreestanding -nostdinc -isystem /local/yocto/upstream/label/ubuntu1204-64b/machine/beagleboard/poky/edison/tmp/sysroots/x86_64-linux/usr/bin/armv7a-vfp-neon-poky-linux-gnueabi/../../lib/armv7a-vfp-neon-poky-linux-gnueabi/gcc/arm-poky-linux-gnueabi/4.6.3/include -pipe -DCONFIG_ARM -D__ARM__ -marm -mabi=aapcs-linux -mno-thumb-interwork -march=armv5 -Wall -Wstrict-prototypes -fno-stack-protector -fno-toplevel-reorder -o stubs.o stubs.c -c | arm-poky-linux-gnueabi-ld -r -o libstubs.o stubs.o | arm-poky-linux-gnueabi-ld -g -Ttext 0x80300000 \ | -o hello_world -e hello_world hello_world.o libstubs.o \ | -L. -lgcc | arm-poky-linux-gnueabi-ld: cannot find -lgcc | make[1]: *** [hello_world] Error 1 Signed-off-by: Matthew McClintock <msm@freescale.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-bsp')
-rw-r--r--meta/recipes-bsp/u-boot/u-boot.inc2
-rw-r--r--meta/recipes-bsp/u-boot/u-boot_2011.03.bb2
-rw-r--r--meta/recipes-bsp/u-boot/u-boot_2011.06.bb2
-rw-r--r--meta/recipes-bsp/u-boot/u-boot_2012.04.01.bb1
4 files changed, 4 insertions, 3 deletions
diff --git a/meta/recipes-bsp/u-boot/u-boot.inc b/meta/recipes-bsp/u-boot/u-boot.inc
index f794a2ac31..42bdde9ba6 100644
--- a/meta/recipes-bsp/u-boot/u-boot.inc
+++ b/meta/recipes-bsp/u-boot/u-boot.inc
@@ -5,7 +5,7 @@ PROVIDES = "virtual/bootloader"
inherit deploy
-EXTRA_OEMAKE = "CROSS_COMPILE=${TARGET_PREFIX}"
+EXTRA_OEMAKE = 'CROSS_COMPILE=${TARGET_PREFIX} CC="${TARGET_PREFIX}gcc ${TOOLCHAIN_OPTIONS}"'
python () {
if not d.getVar("UBOOT_MACHINE", True):
diff --git a/meta/recipes-bsp/u-boot/u-boot_2011.03.bb b/meta/recipes-bsp/u-boot/u-boot_2011.03.bb
index ed38f54eb1..84653958c9 100644
--- a/meta/recipes-bsp/u-boot/u-boot_2011.03.bb
+++ b/meta/recipes-bsp/u-boot/u-boot_2011.03.bb
@@ -15,7 +15,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=1707d6db1d42237583f50183a5651ecb \
SRCREV = "19b54a701811220221fc4d5089a2bb18892018ca"
PV = "v2011.03+git${SRCPV}"
-PR = "r6"
+PR = "r7"
SRC_URI = "git://git.denx.de/u-boot.git;branch=master;protocol=git"
diff --git a/meta/recipes-bsp/u-boot/u-boot_2011.06.bb b/meta/recipes-bsp/u-boot/u-boot_2011.06.bb
index da61852107..9654795744 100644
--- a/meta/recipes-bsp/u-boot/u-boot_2011.06.bb
+++ b/meta/recipes-bsp/u-boot/u-boot_2011.06.bb
@@ -15,7 +15,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=1707d6db1d42237583f50183a5651ecb \
SRCREV = "b1af6f532e0d348b153d5c148369229d24af361a"
PV = "v2011.06+git${SRCPV}"
-PR = "r1"
+PR = "r2"
SRC_URI = "git://git.denx.de/u-boot.git;branch=master;protocol=git"
diff --git a/meta/recipes-bsp/u-boot/u-boot_2012.04.01.bb b/meta/recipes-bsp/u-boot/u-boot_2012.04.01.bb
index 25cc8c9f03..c4ec50d6aa 100644
--- a/meta/recipes-bsp/u-boot/u-boot_2012.04.01.bb
+++ b/meta/recipes-bsp/u-boot/u-boot_2012.04.01.bb
@@ -20,6 +20,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=1707d6db1d42237583f50183a5651ecb"
SRCREV = "415d386877df49eb051b85ef74fa59a16dc17c7d"
PV = "v2012.04.01+git${SRCPV}"
+PR = "r1"
SRC_URI = "git://git.denx.de/u-boot.git;branch=master;protocol=git"