aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp
diff options
context:
space:
mode:
authorAlejandro del Castillo <alejandro.delcastillo@ni.com>2016-08-16 17:00:30 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-08-18 09:27:53 +0100
commit10e44fe6fb9f0676dfd4ef10f79eceac61011874 (patch)
treececd01bc8d089f4cb5b23883456d502268afdf70 /meta/recipes-bsp
parent2973bc2b293a6bced9413c13643d4f213b2308fb (diff)
downloadopenembedded-core-contrib-10e44fe6fb9f0676dfd4ef10f79eceac61011874.tar.gz
grub: split grub-editenv into it's own package
grub-editenv edits the env block at runtime on a booted system. Other tools can depend on it to configure a live system, for ex. to set next boot mode upon reboot. By splitting grub-editenv, tools don't have to depend on the entire grub package (grub-editenv just edits one file). (From OE-Core rev: 24b832b6e31c4e358d0c7a0062b69f66469cdcee) Signed-off-by: Alejandro del Castillo <alejandro.delcastillo@ni.com> Signed-off-by: Ioan-Adrian Ratiu <adrian.ratiu@ni.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-bsp')
-rw-r--r--meta/recipes-bsp/grub/grub_2.00.bb6
1 files changed, 5 insertions, 1 deletions
diff --git a/meta/recipes-bsp/grub/grub_2.00.bb b/meta/recipes-bsp/grub/grub_2.00.bb
index 778074a387..07e1d101b3 100644
--- a/meta/recipes-bsp/grub/grub_2.00.bb
+++ b/meta/recipes-bsp/grub/grub_2.00.bb
@@ -1,6 +1,6 @@
require grub2.inc
-RDEPENDS_${PN} = "diffutils freetype"
+RDEPENDS_${PN} = "diffutils freetype grub-editenv"
PR = "r1"
EXTRA_OECONF = "--with-platform=pc --disable-grub-mkfont --program-prefix="" \
@@ -8,6 +8,10 @@ EXTRA_OECONF = "--with-platform=pc --disable-grub-mkfont --program-prefix="" \
EXTRA_OECONF += "${@bb.utils.contains('DISTRO_FEATURES', 'largefile', '--enable-largefile', '--disable-largefile', d)}"
+PACKAGES =+ "grub-editenv"
+
+FILES_grub-editenv = "${bindir}/grub-editenv"
+
do_install_append () {
install -d ${D}${sysconfdir}/grub.d
}