summaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp
diff options
context:
space:
mode:
authorDaisuke Yamane <yamane07ynct@gmail.com>2020-01-23 10:33:32 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-01-27 16:38:54 +0000
commit8bd7a19b0177cc842d0fabfb9a602208c0617d9e (patch)
treeec1d705373f6b421662e9a42f956a08742df18a1 /meta/recipes-bsp
parentbb526eee429f25b85372f41e4d6d2865bcc39173 (diff)
downloadopenembedded-core-contrib-8bd7a19b0177cc842d0fabfb9a602208c0617d9e.tar.gz
u-boot-tools: Add capability of building from out-of-tree
This patch also helps to build with EXTERNALSRC. Signed-off-by: Daisuke Yamane <yamane07ynct@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-bsp')
-rw-r--r--meta/recipes-bsp/u-boot/u-boot-tools_2020.01.bb6
1 files changed, 3 insertions, 3 deletions
diff --git a/meta/recipes-bsp/u-boot/u-boot-tools_2020.01.bb b/meta/recipes-bsp/u-boot/u-boot-tools_2020.01.bb
index bede984ef7..414ee333ff 100644
--- a/meta/recipes-bsp/u-boot/u-boot-tools_2020.01.bb
+++ b/meta/recipes-bsp/u-boot/u-boot-tools_2020.01.bb
@@ -25,14 +25,14 @@ SED_CONFIG_EFI_armeb = ''
SED_CONFIG_EFI_aarch64 = ''
do_compile () {
- oe_runmake sandbox_defconfig
+ oe_runmake -C ${S} sandbox_defconfig O=${B}
# Disable CONFIG_CMD_LICENSE, license.h is not used by tools and
# generating it requires bin2header tool, which for target build
# is built with target tools and thus cannot be executed on host.
- sed -i -e "s/CONFIG_CMD_LICENSE=.*/# CONFIG_CMD_LICENSE is not set/" ${SED_CONFIG_EFI} .config
+ sed -i -e "s/CONFIG_CMD_LICENSE=.*/# CONFIG_CMD_LICENSE is not set/" ${SED_CONFIG_EFI} ${B}/.config
- oe_runmake cross_tools NO_SDL=1
+ oe_runmake -C ${S} cross_tools NO_SDL=1 O=${B}
}
do_install () {