aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2011-05-30 14:01:49 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-06-02 14:47:25 +0100
commit4089a58253f69eff5eb7d97a67f1b61ee08057f4 (patch)
tree38d765ce6f71bdcc028d6a2c3ea1f96833080911 /meta/recipes-bsp
parentae18e38fae93f9a21eb050975f321c8e80b44e14 (diff)
downloadopenembedded-core-contrib-4089a58253f69eff5eb7d97a67f1b61ee08057f4.tar.gz
u-boot: package up u-boot.bin for field upgrades
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta/recipes-bsp')
-rw-r--r--meta/recipes-bsp/uboot/u-boot.inc11
-rw-r--r--meta/recipes-bsp/uboot/u-boot_2011.03.bb2
2 files changed, 12 insertions, 1 deletions
diff --git a/meta/recipes-bsp/uboot/u-boot.inc b/meta/recipes-bsp/uboot/u-boot.inc
index 83dfb6fa86..2be9fc9ebe 100644
--- a/meta/recipes-bsp/uboot/u-boot.inc
+++ b/meta/recipes-bsp/uboot/u-boot.inc
@@ -21,6 +21,7 @@ python () {
}
UBOOT_IMAGE ?= "u-boot-${MACHINE}-${PV}-${PR}.bin"
+UBOOT_BINARY ?= "u-boot.bin"
UBOOT_SYMLINK ?= "u-boot-${MACHINE}.bin"
UBOOT_MAKE_TARGET ?= "all"
@@ -32,6 +33,16 @@ do_compile () {
oe_runmake ${UBOOT_MAKE_TARGET}
}
+do_install () {
+ install -d ${D}/boot
+ install ${S}/${UBOOT_BINARY} ${D}/boot/${UBOOT_IMAGE}
+ ln -sf ${UBOOT_IMAGE} ${D}/boot/${UBOOT_BINARY}
+}
+
+FILES_${PN} = "/boot"
+# no gnu_hash in uboot.bin, by design, so skip QA
+INSANE_SKIP_${PN} = True
+
do_deploy () {
install ${S}/u-boot.bin ${DEPLOYDIR}/${UBOOT_IMAGE}
diff --git a/meta/recipes-bsp/uboot/u-boot_2011.03.bb b/meta/recipes-bsp/uboot/u-boot_2011.03.bb
index 0fbb9ba188..07f0609194 100644
--- a/meta/recipes-bsp/uboot/u-boot_2011.03.bb
+++ b/meta/recipes-bsp/uboot/u-boot_2011.03.bb
@@ -14,7 +14,7 @@ FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/u-boot-git/${MACHINE
SRCREV = "v2011.03"
PV = "v2011.03+git${SRCPV}"
-PR="r3"
+PR="r4"
SRC_URI = "git://git.denx.de/u-boot.git;branch=master;protocol=git"