aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp
diff options
context:
space:
mode:
authorKoen Kooi <koen.kooi@linaro.org>2014-04-14 10:03:37 +0200
committerSaul Wold <sgw@linux.intel.com>2014-05-23 09:09:39 -0700
commit98491d69c573bc113995075331cabef7f9d1a675 (patch)
tree693dc61da5577f0dc10c744986ef0eb95fe8dc99 /meta/recipes-bsp
parent9f29399dcb9eea02efbda14cc3d5bcf2e91323f6 (diff)
downloadopenembedded-core-contrib-98491d69c573bc113995075331cabef7f9d1a675.tar.gz
grub git: workaround debugedit problems
Debugedit errors out on bare metal binaries. The first version of this patch limited it to 64 bit targets, but the problem now shows up on 32 bit targets (minnowboard) as well. (From OE-Core rev: f95c7611007ddda3fe36db90168c7d5de096f9cd) Signed-off-by: Koen Kooi <koen.kooi@linaro.org> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-bsp')
-rw-r--r--meta/recipes-bsp/grub/grub_git.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/meta/recipes-bsp/grub/grub_git.bb b/meta/recipes-bsp/grub/grub_git.bb
index 9b5d9bbd7d..114cf77de9 100644
--- a/meta/recipes-bsp/grub/grub_git.bb
+++ b/meta/recipes-bsp/grub/grub_git.bb
@@ -53,8 +53,12 @@ do_configure_prepend() {
do_install_append () {
install -d ${D}${sysconfdir}/grub.d
install -m 0755 ${WORKDIR}/40_custom ${D}${sysconfdir}/grub.d/40_custom
+
}
+# debugedit chokes on bare metal binaries
+INHIBIT_PACKAGE_DEBUG_SPLIT = "1"
+
RDEPENDS_${PN} = "diffutils freetype"
FILES_${PN}-dbg += "${libdir}/${BPN}/*/.debug"