aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp/u-boot/u-boot.inc
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2012-08-02 14:09:50 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-08-02 14:58:51 +0100
commitf78044f85ab1a0acce852a7032fc0c81285cd4c1 (patch)
treee7440b60be67916c8776985159ab6a7ccfa2fab9 /meta/recipes-bsp/u-boot/u-boot.inc
parent404d2d490fc347203e89d274530c17fb5f0aa20f (diff)
downloadopenembedded-core-contrib-f78044f85ab1a0acce852a7032fc0c81285cd4c1.tar.gz
u-boot.inc: fix regexp used when ld-is-gold
* with old regexp it wasn't reentrant, causing stuff like this: -LD = $(CROSS_COMPILE)ld +LD = $(CROSS_COMPILE)ld.bfd.bfd -LDR = $(CROSS_COMPILE)ldr +LDR = $(CROSS_COMPILE)ld.bfd.bfdr when do_compile was reexecuted, also breaking LDR variable and http://git.yoctoproject.org/cgit/cgit.cgi/meta-ti/tree/recipes-bsp/u-boot/u-boot/0001-config-Always-use-GNU-ld.patch when it was used together with u-boot.inc from oe-core (meta-ti is using own u-boot.inc) * This patch is also better solution to ld-is-gold problem then regexp in metadata. Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-bsp/u-boot/u-boot.inc')
-rw-r--r--meta/recipes-bsp/u-boot/u-boot.inc2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-bsp/u-boot/u-boot.inc b/meta/recipes-bsp/u-boot/u-boot.inc
index 42bdde9ba6..a8642f0b06 100644
--- a/meta/recipes-bsp/u-boot/u-boot.inc
+++ b/meta/recipes-bsp/u-boot/u-boot.inc
@@ -34,7 +34,7 @@ SPL_SYMLINK ?= "${SPL_BINARY}-${MACHINE}"
do_compile () {
if [ "${@base_contains('DISTRO_FEATURES', 'ld-is-gold', 'ld-is-gold', '', d)}" = "ld-is-gold" ] ; then
- sed -i 's/$(CROSS_COMPILE)ld/$(CROSS_COMPILE)ld.bfd/g' config.mk
+ sed -i 's/$(CROSS_COMPILE)ld$/$(CROSS_COMPILE)ld.bfd/g' config.mk
fi
unset LDFLAGS