aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp/u-boot/u-boot-mkimage_2016.03.bb
diff options
context:
space:
mode:
authorMarek Vasut <marex@denx.de>2016-10-18 23:55:09 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-10-28 16:15:19 +0100
commita40f5d34065129ab19a3c981cbb38f854e9ae0ec (patch)
tree8ec6ab78d8c0a0e7a531ec33ff61712bfa0d2d28 /meta/recipes-bsp/u-boot/u-boot-mkimage_2016.03.bb
parent2031738d28768ebd95cce9c355521142dd1a88c4 (diff)
downloadopenembedded-core-contrib-a40f5d34065129ab19a3c981cbb38f854e9ae0ec.tar.gz
u-boot: Factor out common bits
The u-boot recipes share a couple of common variables, which makes updating of the recipes error prone and a toil. Factor those common bits into u-boot-common_${PV}.inc so that they are in one place. The u-boot_${PV}.bb now explicitly require u-boot-common_${PV}.inc before require u-boot.inc , as doing require u-boot-common_${PV}.inc from u-boot.inc would fail due to ${PV} not being set. This is a functional change. (From OE-Core rev: b36056af20e981433f143556d511dec5644930fc) Signed-off-by: Marek Vasut <marex@denx.de> Cc: Richard Purdie <richard.purdie@linuxfoundation.org> Cc: Denys Dmytriyenko <denis@denix.org> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-bsp/u-boot/u-boot-mkimage_2016.03.bb')
-rw-r--r--meta/recipes-bsp/u-boot/u-boot-mkimage_2016.03.bb17
1 files changed, 2 insertions, 15 deletions
diff --git a/meta/recipes-bsp/u-boot/u-boot-mkimage_2016.03.bb b/meta/recipes-bsp/u-boot/u-boot-mkimage_2016.03.bb
index d5921a0443..5025961f91 100644
--- a/meta/recipes-bsp/u-boot/u-boot-mkimage_2016.03.bb
+++ b/meta/recipes-bsp/u-boot/u-boot-mkimage_2016.03.bb
@@ -1,21 +1,8 @@
-SUMMARY = "U-Boot bootloader image creation tool"
-LICENSE = "GPLv2+"
-LIC_FILES_CHKSUM = "file://Licenses/README;md5=a2c678cfd4a4d97135585cad908541c6"
-SECTION = "bootloader"
+require u-boot-common_${PV}.inc
+SUMMARY = "U-Boot bootloader image creation tool"
DEPENDS = "openssl"
-# This revision corresponds to the tag "v2016.03"
-# We use the revision in order to avoid having to fetch it from the
-# repo during parse
-SRCREV = "df61a74e6845ec9bdcdd48d2aff5e9c2c6debeaa"
-
-PV = "v2016.03+git${SRCPV}"
-
-SRC_URI = "git://git.denx.de/u-boot.git;branch=master"
-
-S = "${WORKDIR}/git"
-
EXTRA_OEMAKE = 'CROSS_COMPILE="${TARGET_PREFIX}" CC="${CC} ${CFLAGS} ${LDFLAGS}" STRIP=true V=1'
do_compile () {