aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp/u-boot/u-boot-fw-utils_2016.11.bb
diff options
context:
space:
mode:
authorMarek Vasut <marex@denx.de>2016-11-18 11:18:58 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-12-08 10:26:14 +0000
commit34f1d3824fd45cd0bb28b3cbc33907cfd885f841 (patch)
treeb529c1f7ff45902bb137d72242dc6962188357e0 /meta/recipes-bsp/u-boot/u-boot-fw-utils_2016.11.bb
parentc2980c1d2fe127d56d4c1b797df5a1047d0e2db0 (diff)
downloadopenembedded-core-contrib-34f1d3824fd45cd0bb28b3cbc33907cfd885f841.tar.gz
u-boot: Update to v2016.11 release
Upgrade U-Boot to the latest version. Signed-off-by: Marek Vasut <marex@denx.de> Cc: Richard Purdie <richard.purdie@linuxfoundation.org> Cc: Denys Dmytriyenko <denis@denix.org> Cc: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-bsp/u-boot/u-boot-fw-utils_2016.11.bb')
-rw-r--r--meta/recipes-bsp/u-boot/u-boot-fw-utils_2016.11.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/meta/recipes-bsp/u-boot/u-boot-fw-utils_2016.11.bb b/meta/recipes-bsp/u-boot/u-boot-fw-utils_2016.11.bb
new file mode 100644
index 0000000000..f56862cb27
--- /dev/null
+++ b/meta/recipes-bsp/u-boot/u-boot-fw-utils_2016.11.bb
@@ -0,0 +1,34 @@
+require u-boot-common_${PV}.inc
+
+SUMMARY = "U-Boot bootloader fw_printenv/setenv utilities"
+DEPENDS = "mtd-utils"
+
+INSANE_SKIP_${PN} = "already-stripped"
+EXTRA_OEMAKE_class-target = 'CROSS_COMPILE=${TARGET_PREFIX} CC="${CC} ${CFLAGS} ${LDFLAGS}" V=1'
+EXTRA_OEMAKE_class-cross = 'ARCH=${TARGET_ARCH} CC="${CC} ${CFLAGS} ${LDFLAGS}" V=1'
+
+inherit uboot-config
+
+do_compile () {
+ oe_runmake ${UBOOT_MACHINE}
+ oe_runmake env
+}
+
+do_install () {
+ install -d ${D}${base_sbindir}
+ install -d ${D}${sysconfdir}
+ install -m 755 ${S}/tools/env/fw_printenv ${D}${base_sbindir}/fw_printenv
+ install -m 755 ${S}/tools/env/fw_printenv ${D}${base_sbindir}/fw_setenv
+ install -m 0644 ${S}/tools/env/fw_env.config ${D}${sysconfdir}/fw_env.config
+}
+
+do_install_class-cross () {
+ install -d ${D}${bindir_cross}
+ install -m 755 ${S}/tools/env/fw_printenv ${D}${bindir_cross}/fw_printenv
+ install -m 755 ${S}/tools/env/fw_printenv ${D}${bindir_cross}/fw_setenv
+}
+
+SYSROOT_DIRS_append_class-cross = " ${bindir_cross}"
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+BBCLASSEXTEND = "cross"