aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp/u-boot/u-boot-fw-utils_2014.07.bb
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2015-01-22 23:18:27 -0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-01-28 21:23:02 +0000
commite9e0235f64250614c79f1749843f5559be32fefd (patch)
treee70d69d67d84c0f8a6b2a7dddf2a7bcb0ca4adf0 /meta/recipes-bsp/u-boot/u-boot-fw-utils_2014.07.bb
parent510837cacdc98acc42ea36bd5bd1841dbff418e4 (diff)
downloadopenembedded-core-contrib-e9e0235f64250614c79f1749843f5559be32fefd.tar.gz
u-boot-fw-utils: Fix the cross build
This merges the u-boot-fw-utils-cross into the main u-boot-fw-utils recipe and fixes the build failure seen since 2014.07 update. The cross package now is handled using an extended class instead of a duplicated recipe. Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-bsp/u-boot/u-boot-fw-utils_2014.07.bb')
-rw-r--r--meta/recipes-bsp/u-boot/u-boot-fw-utils_2014.07.bb12
1 files changed, 12 insertions, 0 deletions
diff --git a/meta/recipes-bsp/u-boot/u-boot-fw-utils_2014.07.bb b/meta/recipes-bsp/u-boot/u-boot-fw-utils_2014.07.bb
index a626c9599a..9a304c8c5d 100644
--- a/meta/recipes-bsp/u-boot/u-boot-fw-utils_2014.07.bb
+++ b/meta/recipes-bsp/u-boot/u-boot-fw-utils_2014.07.bb
@@ -32,4 +32,16 @@ do_install () {
install -m 0644 ${S}/tools/env/fw_env.config ${D}${sysconfdir}/fw_env.config
}
+do_install_class-cross () {
+ install -d ${D}${bindir_cross}
+ install -m 755 ${S}/tools/env/fw_printenv ${D}${bindir_cross}/fw_printenv
+ install -m 755 ${S}/tools/env/fw_printenv ${D}${bindir_cross}/fw_setenv
+}
+
+SYSROOT_PREPROCESS_FUNCS_class-cross = "uboot_fw_utils_cross"
+uboot_fw_utils_cross() {
+ sysroot_stage_dir ${D}${bindir_cross} ${SYSROOT_DESTDIR}${bindir_cross}
+}
+
PACKAGE_ARCH = "${MACHINE_ARCH}"
+BBCLASSEXTEND = "cross"