summaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp/u-boot/libubootenv_0.3.1.bb
diff options
context:
space:
mode:
authorPierre-Jean Texier <pjtexier@koncepto.io>2020-09-12 15:37:08 +0200
committerSteve Sakoman <steve@sakoman.com>2020-09-14 04:49:12 -1000
commit2e646f0aca9a0af7e308590117c220c940996d86 (patch)
treedb74d6018077695ff7134abceaf432d030243a58 /meta/recipes-bsp/u-boot/libubootenv_0.3.1.bb
parent16bad6260a6a25b2ec25c7eb0dfe526db56f166e (diff)
downloadopenembedded-core-contrib-2e646f0aca9a0af7e308590117c220c940996d86.tar.gz
libubootenv: upgrade 0.3 -> 0.3.1
This is a bugfix release which includes the following changes: 824551a Prepare 0.3.1 ca6aaa1 Fix file reading/writing when the environment is in EEPROM a031dea Fix regression in UBI volume support c91c150 Define SOVERSION to indicate API version Signed-off-by: Pierre-Jean Texier <pjtexier@koncepto.io> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> (cherry picked from commit 447eb941ef43cd5af19aed650fb7da718cedda61) Signed-off-by: Steve Sakoman <steve@sakoman.com>
Diffstat (limited to 'meta/recipes-bsp/u-boot/libubootenv_0.3.1.bb')
-rw-r--r--meta/recipes-bsp/u-boot/libubootenv_0.3.1.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta/recipes-bsp/u-boot/libubootenv_0.3.1.bb b/meta/recipes-bsp/u-boot/libubootenv_0.3.1.bb
new file mode 100644
index 0000000000..613e3161fb
--- /dev/null
+++ b/meta/recipes-bsp/u-boot/libubootenv_0.3.1.bb
@@ -0,0 +1,30 @@
+SUMMARY = "U-Boot libraries and tools to access environment"
+
+DESCRIPTION = "This package contains tools and libraries to read \
+and modify U-Boot environment. \
+It provides a hardware-independent replacement for fw_printenv/setenv utilities \
+provided by U-Boot"
+
+HOMEPAGE = "https://github.com/sbabic/libubootenv"
+LICENSE = "LGPL-2.1"
+LIC_FILES_CHKSUM = "file://Licenses/lgpl-2.1.txt;md5=4fbd65380cdd255951079008b364516c"
+SECTION = "libs"
+
+SRC_URI = "git://github.com/sbabic/libubootenv;protocol=https"
+SRCREV = "824551ac77bab1d0f7ae34d7a7c77b155240e754"
+
+S = "${WORKDIR}/git"
+
+inherit uboot-config cmake lib_package
+
+EXTRA_OECMAKE = "-DCMAKE_BUILD_TYPE=Release"
+
+DEPENDS = "zlib"
+PROVIDES += "u-boot-fw-utils"
+RPROVIDES_${PN}-bin += "u-boot-fw-utils"
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+RRECOMMENDS_${PN}-bin_append_class-target = " u-boot-default-env"
+
+BBCLASSEXTEND = "native"