aboutsummaryrefslogtreecommitdiffstats
path: root/meta/packages/pth
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openedhand.com>2008-03-25 11:51:45 +0000
committerMarcin Juszkiewicz <hrw@openedhand.com>2008-03-25 11:51:45 +0000
commitb33f6c2843b58acd036eb06ba6ffa0b1ca18e801 (patch)
tree02d6fa619bbb0f76edafccbdce9b83c1169029ab /meta/packages/pth
parent8f84474b504d306b6bd16b4fadbe6fbb1c2285e9 (diff)
downloadopenembedded-core-contrib-b33f6c2843b58acd036eb06ba6ffa0b1ca18e801.tar.gz
pth: keep binconfig in -dev package
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@4111 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/pth')
-rw-r--r--meta/packages/pth/pth_2.0.7.bb6
1 files changed, 5 insertions, 1 deletions
diff --git a/meta/packages/pth/pth_2.0.7.bb b/meta/packages/pth/pth_2.0.7.bb
index cdb0cf2cb1..ac93a27ebc 100644
--- a/meta/packages/pth/pth_2.0.7.bb
+++ b/meta/packages/pth/pth_2.0.7.bb
@@ -2,12 +2,13 @@ DESCRIPTION = "GNU Portable Threads"
SECTION = "libs"
PRIORITY = "optional"
LICENSE = "GPL LGPL FDL"
+PR = "r1"
SRC_URI = "${GNU_MIRROR}/pth/pth-${PV}.tar.gz"
PARALLEL_MAKE=""
-inherit autotools
+inherit autotools binconfig
do_configure() {
gnu-configize
@@ -26,3 +27,6 @@ do_stage() {
install -d ${STAGING_DATADIR}/aclocal
install pth.m4 ${STAGING_DATADIR}/aclocal/
}
+
+FILES_${PN} = "${libdir}/libpth.so.*"
+FILES_${PN}-dev += "${bindir}/pth-config"