aboutsummaryrefslogtreecommitdiffstats
path: root/meta/packages/pth
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openedhand.com>2008-03-14 10:16:00 +0000
committerMarcin Juszkiewicz <hrw@openedhand.com>2008-03-14 10:16:00 +0000
commit814e308091c18aaf541b31805fa0689447ad23c0 (patch)
tree8707a4a62681ed8a3b25fbbac079f8eeab691c07 /meta/packages/pth
parent362ccc12e1aaab8181d505412c2b9e85fb34117b (diff)
downloadopenembedded-core-contrib-814e308091c18aaf541b31805fa0689447ad23c0.tar.gz
pth: added 2.0.2 (from OE)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@4001 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/pth')
-rw-r--r--meta/packages/pth/pth_2.0.2.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta/packages/pth/pth_2.0.2.bb b/meta/packages/pth/pth_2.0.2.bb
new file mode 100644
index 0000000000..78c06bfd93
--- /dev/null
+++ b/meta/packages/pth/pth_2.0.2.bb
@@ -0,0 +1,29 @@
+DESCRIPTION = "GNU Portable Threads"
+SECTION = "libs"
+PRIORITY = "optional"
+LICENSE = "GPL LGPL FDL"
+PR = "r0"
+
+SRC_URI = "${GNU_MIRROR}/pth/pth-${PV}.tar.gz"
+
+PARALLEL_MAKE=""
+
+inherit autotools
+
+do_configure() {
+ gnu-configize
+ oe_runconf
+}
+
+do_stage() {
+ oe_libinstall -so libpth ${STAGING_LIBDIR}
+
+ install -d ${STAGING_INCDIR}/
+ for X in pth.h
+ do
+ install -m 0644 ${S}/$X ${STAGING_INCDIR}/$X
+ done
+
+ install -d ${STAGING_DATADIR}/aclocal
+ install pth.m4 ${STAGING_DATADIR}/aclocal/
+}