summaryrefslogtreecommitdiffstats
path: root/meta/packages/psplash
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2006-09-28 14:20:06 +0000
committerRichard Purdie <richard@openedhand.com>2006-09-28 14:20:06 +0000
commitb462c8bee52fafc1eade2d913d3a50dc301a3fdf (patch)
tree0121e947fb067c82596a4ab0296acde333393480 /meta/packages/psplash
parentf27a0caa85b3509a0d9fa9ae987243e37c5615fb (diff)
downloadopenembedded-core-contrib-b462c8bee52fafc1eade2d913d3a50dc301a3fdf.tar.gz
add psplash
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@770 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/psplash')
-rwxr-xr-xmeta/packages/psplash/files/psplash-init7
-rw-r--r--meta/packages/psplash/psplash_0.0.bb22
2 files changed, 29 insertions, 0 deletions
diff --git a/meta/packages/psplash/files/psplash-init b/meta/packages/psplash/files/psplash-init
new file mode 100755
index 0000000000..b736cc6375
--- /dev/null
+++ b/meta/packages/psplash/files/psplash-init
@@ -0,0 +1,7 @@
+#!/bin/sh
+
+export TMPDIR=/mnt/.psplash
+mount tmpfs -t tmpfs $TMPDIR -o,size=40k
+
+/usr/bin/psplash &
+
diff --git a/meta/packages/psplash/psplash_0.0.bb b/meta/packages/psplash/psplash_0.0.bb
new file mode 100644
index 0000000000..a64b4c2b79
--- /dev/null
+++ b/meta/packages/psplash/psplash_0.0.bb
@@ -0,0 +1,22 @@
+DESCRIPTION = "Userspace framebuffer boot logo based on usplash."
+SECTION = "base"
+MAINTAINER = "Matthew Allum <mallum@openedhand.com>"
+LICENSE = "GPL"
+
+SRC_URI = "svn://svn.o-hand.com/repos/misc/trunk;module=psplash;proto=http \
+ file://psplash-init"
+
+S = "${WORKDIR}/psplash"
+
+inherit autotools pkgconfig update-rc.d
+
+FILES_${PN} += "/mnt/.psplash"
+
+do_install_prepend() {
+ install -d ${D}/mnt/.psplash/
+ install -d ${D}${sysconfdir}/init.d/
+ install -m 0755 ${WORKDIR}/psplash-init ${D}${sysconfdir}/init.d/psplash
+}
+
+INITSCRIPT_NAME = "psplash"
+INITSCRIPT_PARAMS = "start 0 S . stop 20 0 1 6 ."