aboutsummaryrefslogtreecommitdiffstats
path: root/meta/packages/llvm/llvm-native/fix_ldflags_export.patch
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2010-08-27 15:14:24 +0100
committerRichard Purdie <rpurdie@linux.intel.com>2010-08-27 15:29:45 +0100
commit29d6678fd546377459ef75cf54abeef5b969b5cf (patch)
tree8edd65790e37a00d01c3f203f773fe4b5012db18 /meta/packages/llvm/llvm-native/fix_ldflags_export.patch
parentda49de6885ee1bc424e70bc02f21f6ab920efb55 (diff)
downloadopenembedded-core-contrib-29d6678fd546377459ef75cf54abeef5b969b5cf.tar.gz
Major layout change to the packages directory
Having one monolithic packages directory makes it hard to find things and is generally overwhelming. This commit splits it into several logical sections roughly based on function, recipes.txt gives more information about the classifications used. The opportunity is also used to switch from "packages" to "recipes" as used in OpenEmbedded as the term "packages" can be confusing to people and has many different meanings. Not all recipes have been classified yet, this is just a first pass at separating things out. Some packages are moved to meta-extras as they're no longer actively used or maintained. Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta/packages/llvm/llvm-native/fix_ldflags_export.patch')
-rw-r--r--meta/packages/llvm/llvm-native/fix_ldflags_export.patch26
1 files changed, 0 insertions, 26 deletions
diff --git a/meta/packages/llvm/llvm-native/fix_ldflags_export.patch b/meta/packages/llvm/llvm-native/fix_ldflags_export.patch
deleted file mode 100644
index 77511d68f6..0000000000
--- a/meta/packages/llvm/llvm-native/fix_ldflags_export.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-Index: trunk/tools/llvm-config/Makefile
-===================================================================
---- trunk.orig/tools/llvm-config/Makefile 2008-02-11 15:14:22.000000000 +0000
-+++ trunk/tools/llvm-config/Makefile 2008-04-11 16:58:06.000000000 +0100
-@@ -27,7 +27,7 @@
- # This is blank for now. We need to be careful about adding stuff here:
- # LDFLAGS tend not to be portable, and we don't currently require the
- # user to use libtool when linking against LLVM.
--SUB_LDFLAGS =
-+SUB_LDFLAGS = ${LD.Flags}
-
- FinalLibDeps = $(PROJ_OBJ_DIR)/FinalLibDeps.txt
- LibDeps = $(PROJ_OBJ_DIR)/LibDeps.txt
-@@ -57,10 +57,11 @@
- # Build our final script.
- $(ToolDir)/llvm-config: llvm-config.in $(FinalLibDeps)
- $(Echo) "Building llvm-config script."
-+ $(Echo) 's,@LLVM_LDFLAGS@,$(SUB_LDFLAGS),'
- $(Verb) $(ECHO) 's,@LLVM_CPPFLAGS@,$(SUB_CPPFLAGS),' > temp.sed
- $(Verb) $(ECHO) 's,@LLVM_CFLAGS@,$(SUB_CFLAGS),' >> temp.sed
- $(Verb) $(ECHO) 's,@LLVM_CXXFLAGS@,$(SUB_CXXFLAGS),' >> temp.sed
-- $(Verb) $(ECHO) 's,@LLVM_LDFLAGS@,$(SUB_LDFLAGS),' >> temp.sed
-+ $(Verb) $(ECHO) 's#@LLVM_LDFLAGS@#$(SUB_LDFLAGS)#' >> temp.sed
- $(Verb) $(ECHO) 's,@LLVM_BUILDMODE@,$(BuildMode),' >> temp.sed
- $(Verb) $(SED) -f temp.sed < $< > $@
- $(Verb) $(RM) temp.sed