aboutsummaryrefslogtreecommitdiffstats
path: root/meta/packages/libtool
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2009-09-16 23:09:44 +0100
committerRichard Purdie <rpurdie@linux.intel.com>2009-09-17 22:24:36 +0100
commitaf85ce4b4e675feb5796f87137c86d70c2f15b9a (patch)
treef19dbb9bcf1eec671b26685458f7cc47ebb3721e /meta/packages/libtool
parent046ae6a38d829048663fe1afb1f67de1fbe2e3b5 (diff)
downloadopenembedded-core-contrib-af85ce4b4e675feb5796f87137c86d70c2f15b9a.tar.gz
Remove layout_* variables
Remove layout_* variables and replace them with variables specific to the different classes. The layout variables were only useful for the native/cross classes and caused more confusion than they solved. They didn't scale to the sdk class. It now clear a small set of native/cross variables fulfil the needs. This patch also changes native.bbclass to use "/" as the STAGING_DIR which makes sense since we're installing binaries into the locations we're compiling them for. Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta/packages/libtool')
-rw-r--r--meta/packages/libtool/libtool-cross_2.2.6.bb20
1 files changed, 10 insertions, 10 deletions
diff --git a/meta/packages/libtool/libtool-cross_2.2.6.bb b/meta/packages/libtool/libtool-cross_2.2.6.bb
index 451f5796cd..67f9add9ab 100644
--- a/meta/packages/libtool/libtool-cross_2.2.6.bb
+++ b/meta/packages/libtool/libtool-cross_2.2.6.bb
@@ -1,7 +1,7 @@
require libtool.inc
require libtool_${PV}.bb
-PR = "r23"
+PR = "r24"
PACKAGES = ""
SRC_URI_append = " file://cross_compile.patch;patch=1 \
file://prefix.patch;patch=1"
@@ -15,8 +15,8 @@ DOLT_PATCH_i586 = " file://add_dolt.patch;patch=1"
#SRC_URI_append_linux = "${DOLT_PATCH}"
#SRC_URI_append_linux-gnueabi = "${DOLT_PATCH}"
-prefix = "${STAGING_DIR_NATIVE}${layout_prefix}"
-exec_prefix = "${STAGING_DIR_NATIVE}${layout_exec_prefix}"
+prefix = "${STAGING_DIR_NATIVE}${prefix_native}"
+exec_prefix = "${STAGING_DIR_NATIVE}${prefix_native}"
bindir = "${STAGING_BINDIR_NATIVE}"
do_compile () {
@@ -25,13 +25,13 @@ do_compile () {
do_stage () {
install -m 0755 ${HOST_SYS}-libtool ${bindir}/${HOST_SYS}-libtool
- install -d ${STAGING_DATADIR}/libtool ${STAGING_DATADIR}/aclocal
- install -c ${S}/libltdl/config/config.guess ${STAGING_DATADIR}/libtool/
- install -c ${S}/libltdl/config/config.sub ${STAGING_DATADIR}/libtool/
- install -c -m 0644 ${S}/libltdl/config/ltmain.sh ${STAGING_DATADIR}/libtool/
- install -c -m 0644 ${S}/libltdl/m4/libtool.m4 ${STAGING_DATADIR}/aclocal/
- install -c -m 0644 ${S}/libltdl/m4/ltdl.m4 ${STAGING_DATADIR}/aclocal/
- install -c -m 0644 ${WORKDIR}/dolt.m4 ${STAGING_DATADIR}/aclocal/
+ install -d ${STAGING_DIR_HOST}${target_datadir}/libtool ${STAGING_DIR_HOST}${target_datadir}/aclocal
+ install -c ${S}/libltdl/config/config.guess ${STAGING_DIR_HOST}${target_datadir}/libtool/
+ install -c ${S}/libltdl/config/config.sub ${STAGING_DIR_HOST}${target_datadir}/libtool/
+ install -c -m 0644 ${S}/libltdl/config/ltmain.sh ${STAGING_DIR_HOST}${target_datadir}/libtool/
+ install -c -m 0644 ${S}/libltdl/m4/libtool.m4 ${STAGING_DIR_HOST}${target_datadir}/aclocal/
+ install -c -m 0644 ${S}/libltdl/m4/ltdl.m4 ${STAGING_DIR_HOST}${target_datadir}/aclocal/
+ install -c -m 0644 ${WORKDIR}/dolt.m4 ${STAGING_DIR_HOST}${target_datadir}/aclocal/
}
do_install () {