aboutsummaryrefslogtreecommitdiffstats
path: root/meta/packages/clutter/clutter.inc
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2007-07-10 14:06:27 +0000
committerRichard Purdie <richard@openedhand.com>2007-07-10 14:06:27 +0000
commite02fb94812ca03db5fea0377661ebde1e3f2222e (patch)
tree427497fb886e6497d44ca501fa946bf4da1a5434 /meta/packages/clutter/clutter.inc
parent9e9fe202ec1e79e6712f748197bf92e286e3cfe7 (diff)
downloadopenembedded-core-contrib-e02fb94812ca03db5fea0377661ebde1e3f2222e.tar.gz
Add clutter, clutter-cairo, clutter-gst, aaina and table, excluded from world builds for now
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@2143 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/clutter/clutter.inc')
-rw-r--r--meta/packages/clutter/clutter.inc27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta/packages/clutter/clutter.inc b/meta/packages/clutter/clutter.inc
new file mode 100644
index 0000000000..b5648c4d7a
--- /dev/null
+++ b/meta/packages/clutter/clutter.inc
@@ -0,0 +1,27 @@
+DESCRIPTION = "Clutter graphics library"
+HOMEPAGE = "http://www.clutter-project.org/"
+LICENSE = "LGPL"
+
+STDDEPENDS = "virtual/libx11 gtk-doc pango glib-2.0 libxfixes"
+BASE_CONF = "--disable-gtk-doc ${@get_clutter_fpu_setting(bb, d)}"
+
+DEPENDS = "${STDDEPENDS}"
+EXTRA_OECONF = "${BASE_CONF}"
+
+inherit autotools pkgconfig
+
+#check for TARGET_FPU=soft and inform configure of the result so it can disable some floating points
+require clutter-fpu.inc
+
+#Fix up some weirdness in the docs
+do_configure_prepend() {
+ touch ${S}/gtk-doc.make
+ sed -i s:doc/reference/Makefile::g ${S}/configure.ac
+ sed -i s:doc::g ${S}/Makefile.am
+}
+
+do_stage () {
+ cp ${S}/clutter.pc ${S}/clutter-0.3.pc
+ autotools_stage_all
+}
+