summaryrefslogtreecommitdiffstats
path: root/meta/lib
diff options
context:
space:
mode:
authorMark Asselstine <mark.asselstine@windriver.com>2019-08-22 11:56:16 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-09-06 08:15:45 +0100
commitf24aedeff83ea7b36de50985bbe600075a20e2b4 (patch)
tree22b0db84090e71e0e824440a65b57152845a833b /meta/lib
parentbf2e0b039a036f3e3f21d05c9dff843d0d293994 (diff)
downloadopenembedded-core-contrib-f24aedeff83ea7b36de50985bbe600075a20e2b4.tar.gz
sdkext: use simpler kernel module for devtool test
The current devtool test for the building of an out-of-tree kernel module uses something which requires several "high order" kconfigs to be set. This results in the test failing, not for expected reasons, but rather because it depends on specific kernel configuration. You will get error messages such as ERROR: "video_ioctl2" [.../1.0-r5/testsdkext/workspace/sources/v4l2loopback-driver/v4l2loopback.ko] undefined! ERROR: "video_unregister_device" [.../1.0-r5/testsdkext/workspace/sources/v4l2loopback-driver/v4l2loopback.ko] undefined! Using a simpler hello-world kernel module example will only require that CONFIG_MODULE is enabled, thus avoiding a false positive. (From OE-Core rev: 48ad9cffa5f9412a8225c61be7e3528e2bdad095) Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/lib')
-rw-r--r--meta/lib/oeqa/manual/crops.json12
-rw-r--r--meta/lib/oeqa/sdkext/cases/devtool.py4
2 files changed, 8 insertions, 8 deletions
diff --git a/meta/lib/oeqa/manual/crops.json b/meta/lib/oeqa/manual/crops.json
index 1cf3c8f30c..5cfa653843 100644
--- a/meta/lib/oeqa/manual/crops.json
+++ b/meta/lib/oeqa/manual/crops.json
@@ -234,16 +234,16 @@
"expected_results": "this should output the directory of the devtool script and it should be within the sdk workdir you are working in. \n\n"
},
"5": {
- "action": "devtool add v4l2loopback-driver https://github.com/umlaeute/v4l2loopback.git \n\n",
- "expected_results": "This should automatically create the recipe v4l2loopback-driver.bb under <crops-esdk-workdir-workspace>/recipes/v4l2loopback-driver/v4l2loopback-driver.bb "
+ "action": "devtool add kernel-module-hello-world https://git.yoctoproject.org/git/kernel-module-hello-world \n\n",
+ "expected_results": "This should automatically create the recipe kernel-module-hello-world.bb under <crops-esdk-workdir-workspace>/recipes/kernel-module-hello-world/kernel-module-hello-world.bb "
},
"6": {
- "action": "devtool build v4l2loopback-driver \n\n",
+ "action": "devtool build kernel-module-hello-world \n\n",
"expected_results": "This should compile an image \n\n"
},
"7": {
- "action": "devtool reset v4l2loopback-driver ",
- "expected_results": "This cleans sysroot of the v4l2loopback-driver recipe, but it leaves the source tree intact. meaning it does not erase."
+ "action": "devtool reset kernel-module-hello-world ",
+ "expected_results": "This cleans sysroot of the kernel-module-hello-world recipe, but it leaves the source tree intact. meaning it does not erase."
}
},
"summary": "sdkext_devtool_kernelmodule"
@@ -291,4 +291,4 @@
"summary": "sdkext_recipes_for_nodejs"
}
}
-] \ No newline at end of file
+]
diff --git a/meta/lib/oeqa/sdkext/cases/devtool.py b/meta/lib/oeqa/sdkext/cases/devtool.py
index 5a02add764..8e92bf8064 100644
--- a/meta/lib/oeqa/sdkext/cases/devtool.py
+++ b/meta/lib/oeqa/sdkext/cases/devtool.py
@@ -73,8 +73,8 @@ class DevtoolTest(OESDKExtTestCase):
self._run('devtool reset %s' % recipe)
def test_devtool_kernelmodule(self):
- docfile = 'https://github.com/umlaeute/v4l2loopback.git'
- recipe = 'v4l2loopback-driver'
+ docfile = 'https://git.yoctoproject.org/git/kernel-module-hello-world'
+ recipe = 'kernel-module-hello-world'
self._run('devtool add %s %s' % (recipe, docfile) )
try:
self._run('devtool build %s' % recipe)