aboutsummaryrefslogtreecommitdiffstats
path: root/meta/lib/oeqa
diff options
context:
space:
mode:
authorJose Perez Carranza <jose.perez.carranza@linux.intel.com>2016-11-24 11:22:32 -0600
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-11-30 15:48:08 +0000
commitb81477d329329bca2de63f4174e4d7aeb749f1dd (patch)
tree1bb8a8502dd6cc8dd832b74fc4ad9fc121dba6fe /meta/lib/oeqa
parent8a00c404ab7717c50bc43d12b78bede1d68c109e (diff)
downloadopenembedded-core-contrib-b81477d329329bca2de63f4174e4d7aeb749f1dd.tar.gz
runtime: Update test cases numbers for runtime tests
Update test case numbers on runtime tests to do match with templates defined on Testopia for 2.3 release (From OE-Core rev: d9df762b4c62b74f6d3a1521642ea86c26793a22) Signed-off-by: Jose Perez Carranza <jose.perez.carranza@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/lib/oeqa')
-rw-r--r--meta/lib/oeqa/runtime/buildgalculator.py1
-rw-r--r--meta/lib/oeqa/runtime/kernelmodule.py2
-rw-r--r--meta/lib/oeqa/runtime/logrotate.py3
-rw-r--r--meta/lib/oeqa/runtime/pam.py2
4 files changed, 5 insertions, 3 deletions
diff --git a/meta/lib/oeqa/runtime/buildgalculator.py b/meta/lib/oeqa/runtime/buildgalculator.py
index 28ba29e5c2..220101d55c 100644
--- a/meta/lib/oeqa/runtime/buildgalculator.py
+++ b/meta/lib/oeqa/runtime/buildgalculator.py
@@ -7,6 +7,7 @@ def setUpModule():
skipModule("Image doesn't have tools-sdk in IMAGE_FEATURES")
class GalculatorTest(oeRuntimeTest):
+ @testcase(1526)
@skipUnlessPassed("test_ssh")
def test_galculator(self):
try:
diff --git a/meta/lib/oeqa/runtime/kernelmodule.py b/meta/lib/oeqa/runtime/kernelmodule.py
index 38ca184540..2ac1bc93d4 100644
--- a/meta/lib/oeqa/runtime/kernelmodule.py
+++ b/meta/lib/oeqa/runtime/kernelmodule.py
@@ -14,7 +14,7 @@ class KernelModuleTest(oeRuntimeTest):
self.target.copy_to(os.path.join(oeRuntimeTest.tc.filesdir, "hellomod.c"), "/tmp/hellomod.c")
self.target.copy_to(os.path.join(oeRuntimeTest.tc.filesdir, "hellomod_makefile"), "/tmp/Makefile")
- @testcase('316')
+ @testcase('1541')
@skipUnlessPassed('test_ssh')
@skipUnlessPassed('test_gcc_compile')
def test_kernel_module(self):
diff --git a/meta/lib/oeqa/runtime/logrotate.py b/meta/lib/oeqa/runtime/logrotate.py
index de300bf55f..cf88c54dfa 100644
--- a/meta/lib/oeqa/runtime/logrotate.py
+++ b/meta/lib/oeqa/runtime/logrotate.py
@@ -12,6 +12,7 @@ def setUpModule():
class LogrotateTest(oeRuntimeTest):
+ @testcase(1544)
@skipUnlessPassed("test_ssh")
def test_1_logrotate_setup(self):
(status, output) = self.target.run('mkdir $HOME/logrotate_dir')
@@ -19,7 +20,7 @@ class LogrotateTest(oeRuntimeTest):
(status, output) = self.target.run("sed -i \"s#wtmp {#wtmp {\\n olddir $HOME/logrotate_dir#\" /etc/logrotate.conf")
self.assertEqual(status, 0, msg = "Could not write to logrotate.conf file. Status and output: %s and %s)" % (status, output))
- @testcase(289)
+ @testcase(1542)
@skipUnlessPassed("test_1_logrotate_setup")
def test_2_logrotate(self):
(status, output) = self.target.run('logrotate -f /etc/logrotate.conf')
diff --git a/meta/lib/oeqa/runtime/pam.py b/meta/lib/oeqa/runtime/pam.py
index c8205c9abc..b7f2dfa49b 100644
--- a/meta/lib/oeqa/runtime/pam.py
+++ b/meta/lib/oeqa/runtime/pam.py
@@ -12,7 +12,7 @@ def setUpModule():
class PamBasicTest(oeRuntimeTest):
- @testcase(287)
+ @testcase(1543)
@skipUnlessPassed('test_ssh')
def test_pam(self):
(status, output) = self.target.run('login --help')