aboutsummaryrefslogtreecommitdiffstats
path: root/meta/lib/oeqa/selftest
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2016-03-28 15:50:54 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-03-28 15:55:49 +0100
commitf81065f5b2313fc4d967c0144b90838f33e6ff60 (patch)
tree2a6f159e4215a512013bb3ba96f7d3df4da30422 /meta/lib/oeqa/selftest
parent25a04eed02096076c25f6edd390b3d1a6daff51c (diff)
downloadopenembedded-core-contrib-f81065f5b2313fc4d967c0144b90838f33e6ff60.tar.gz
selftest/devtool: Update after make PROVIDER changes
Now that make/remake needs a PREFERRED_PROVIDER, we need to set this correctly during tests. (From OE-Core rev: 1a41953331f42d69c0201dcfcbb7d8dc12422fde) Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/lib/oeqa/selftest')
-rw-r--r--meta/lib/oeqa/selftest/devtool.py1
1 files changed, 1 insertions, 0 deletions
diff --git a/meta/lib/oeqa/selftest/devtool.py b/meta/lib/oeqa/selftest/devtool.py
index fe9f7f77a4..32025bed32 100644
--- a/meta/lib/oeqa/selftest/devtool.py
+++ b/meta/lib/oeqa/selftest/devtool.py
@@ -929,6 +929,7 @@ class DevtoolTests(DevtoolBase):
tempdir = tempfile.mkdtemp(prefix='devtoolqa')
# Try devtool extract
self.track_for_cleanup(tempdir)
+ self.append_config('PREFERRED_PROVIDER_virtual/make = "remake"')
result = runCmd('devtool extract remake %s' % tempdir)
self.assertTrue(os.path.exists(os.path.join(tempdir, 'Makefile.am')), 'Extracted source could not be found')
# devtool extract shouldn't create the workspace