aboutsummaryrefslogtreecommitdiffstats
path: root/meta/lib/oeqa/selftest/recipetool.py
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2015-06-25 16:47:28 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-06-26 09:25:51 +0100
commit792107de1586336f4a734557c0c3fa36a1174e9e (patch)
tree1d77de88662a9cc89b6a0a55c1aaa8ce2bbe82fd /meta/lib/oeqa/selftest/recipetool.py
parentde6e0f3af5e858960676ea291036e59105fd806f (diff)
downloadopenembedded-core-contrib-792107de1586336f4a734557c0c3fa36a1174e9e.tar.gz
oeqa/selftest/recipetool: Fix appendfile_binary test on opensuse131
On OpenSUSE 13.1, /bin/ls is a symlink to /usr/bin/ls. This means the test doesn't use a binary file an fails on that system. Ensure we resolve any symlink using readlink to avoid this failure. ====================================================================== FAIL: test_recipetool_appendfile_binary (oeqa.selftest.recipetool.RecipetoolTests) ---------------------------------------------------------------------- Traceback (most recent call last): File "/home/pokybuild/yocto-autobuilder/yocto-worker/nightly-oe-selftest/build/meta/lib/oeqa/selftest/recipetool.py", line 115, in test_recipetool_appendfile_binary self.assertIn('WARNING: ', result.output) AssertionError: 'WARNING: ' not found in 'Parsing recipes..done.\nNOTE: Writing append file /tmp/recipetoolqai0NY8l/recipes-core/coreutils/coreutils_8.23.bbappend\nNOTE: Copying /bin/ls to /tmp/recipetoolqai0NY8l/recipes-core/coreutils/coreutils/ls' [YOCTO #7920] Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/lib/oeqa/selftest/recipetool.py')
-rw-r--r--meta/lib/oeqa/selftest/recipetool.py4
1 files changed, 3 insertions, 1 deletions
diff --git a/meta/lib/oeqa/selftest/recipetool.py b/meta/lib/oeqa/selftest/recipetool.py
index f3ad493457..c08b2e4674 100644
--- a/meta/lib/oeqa/selftest/recipetool.py
+++ b/meta/lib/oeqa/selftest/recipetool.py
@@ -111,7 +111,9 @@ class RecipetoolTests(DevtoolBase):
def test_recipetool_appendfile_binary(self):
# Try appending a binary file
- result = runCmd('recipetool appendfile %s /bin/ls /bin/ls -r coreutils' % templayerdir)
+ # /bin/ls can be a symlink to /usr/bin/ls
+ ls = os.readlink("/bin/ls")
+ result = runCmd('recipetool appendfile %s /bin/ls %s -r coreutils' % (templayerdir, ls))
self.assertIn('WARNING: ', result.output)
self.assertIn('is a binary', result.output)