aboutsummaryrefslogtreecommitdiffstats
path: root/meta/lib/oeqa/selftest/oescripts.py
diff options
context:
space:
mode:
authorJoshua Lock <joshua.g.lock@intel.com>2017-03-08 17:24:16 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-03-10 10:15:44 +0000
commitf8aabeb1a755f3312782a7b64fe863c155510b33 (patch)
tree1bea719a33be690cf92193da01ef2a5d7d4cf4bf /meta/lib/oeqa/selftest/oescripts.py
parent2ac83239698c403bb575e6c5b19f19fcffa389ed (diff)
downloadopenembedded-core-contrib-f8aabeb1a755f3312782a7b64fe863c155510b33.tar.gz
lib/oeqa/selftest/oescripts: make test_cleanup_workdir use selftest-ed
Use a recipe which is bundled in the meta-selftest layer for this test, rather than relying on OE-Core remaining static (or updating the tests when OE-Core changes recipes). Tested with oe-selftest -r oescripts.TestScripts.test_cleanup_workdir Signed-off-by: Joshua Lock <joshua.g.lock@intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/lib/oeqa/selftest/oescripts.py')
-rw-r--r--meta/lib/oeqa/selftest/oescripts.py10
1 files changed, 5 insertions, 5 deletions
diff --git a/meta/lib/oeqa/selftest/oescripts.py b/meta/lib/oeqa/selftest/oescripts.py
index 28345dc6a2..baf3b6ab2c 100644
--- a/meta/lib/oeqa/selftest/oescripts.py
+++ b/meta/lib/oeqa/selftest/oescripts.py
@@ -14,10 +14,10 @@ class TestScripts(oeSelfTest):
@testcase(300)
def test_cleanup_workdir(self):
- path = os.path.dirname(get_bb_var('WORKDIR', 'gzip'))
- old_version_recipe = os.path.join(get_bb_var('COREBASE'), 'meta/recipes-extended/gzip/gzip_1.3.12.bb')
- old_version = '1.3.12'
- bitbake("-c clean gzip")
+ path = os.path.dirname(get_bb_var('WORKDIR', 'selftest-ed'))
+ old_version_recipe = os.path.join(get_bb_var('COREBASE'), 'meta-selftest/recipes-test/selftest-ed/selftest-ed_0.5.bb')
+ old_version = '0.5'
+ bitbake("-c clean selftest-ed")
bitbake("-c clean -b %s" % old_version_recipe)
if os.path.exists(path):
@@ -25,7 +25,7 @@ class TestScripts(oeSelfTest):
else:
initial_contents = []
- bitbake('gzip')
+ bitbake('selftest-ed')
intermediary_contents = os.listdir(path)
bitbake("-b %s" % old_version_recipe)
runCmd('cleanup-workdir')