aboutsummaryrefslogtreecommitdiffstats
path: root/meta/lib/oeqa/selftest/devtool.py
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2015-04-27 10:53:18 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-04-27 15:05:40 +0100
commitbdbeff0cd342e31053d7203d78fc5dda611052b1 (patch)
tree585a5a2f7bbe4f85de7ea6a410b0b997ed9be582 /meta/lib/oeqa/selftest/devtool.py
parentb9fd8d4d4dfae72de2e81e9b14de072e12cecdcf (diff)
downloadopenembedded-core-contrib-bdbeff0cd342e31053d7203d78fc5dda611052b1.tar.gz
devtool: add: use correct bbappend file name with -V option
We weren't adding the version into the bbappend file name when -V was specified which meant that building or resetting failed. Also adjust one of the tests so that we're testing devtool add both with and without this option. Fixes [YOCTO #7647]. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/lib/oeqa/selftest/devtool.py')
-rw-r--r--meta/lib/oeqa/selftest/devtool.py4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta/lib/oeqa/selftest/devtool.py b/meta/lib/oeqa/selftest/devtool.py
index 1a5eecd84c..68818359bc 100644
--- a/meta/lib/oeqa/selftest/devtool.py
+++ b/meta/lib/oeqa/selftest/devtool.py
@@ -150,10 +150,10 @@ class DevtoolTests(oeSelfTest):
result = runCmd('tar xfv libftdi1-1.1.tar.bz2', cwd=tempdir)
srcdir = os.path.join(tempdir, 'libftdi1-1.1')
self.assertTrue(os.path.isfile(os.path.join(srcdir, 'CMakeLists.txt')), 'Unable to find CMakeLists.txt in source directory')
- # Test devtool add
+ # Test devtool add (and use -V so we test that too)
self.track_for_cleanup(workspacedir)
self.add_command_to_tearDown('bitbake-layers remove-layer */workspace')
- result = runCmd('devtool add libftdi %s' % srcdir)
+ result = runCmd('devtool add libftdi %s -V 1.1' % srcdir)
self.assertTrue(os.path.exists(os.path.join(workspacedir, 'conf', 'layer.conf')), 'Workspace directory not created')
# Test devtool status
result = runCmd('devtool status')