aboutsummaryrefslogtreecommitdiffstats
path: root/meta/lib/oeqa/runtime/kernelmodule.py
diff options
context:
space:
mode:
authorMariano Lopez <mariano.lopez@linux.intel.com>2015-10-15 06:29:38 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-10-19 17:57:59 +0100
commitb8f704285f2e00b30f5007217b8575e0820953f1 (patch)
tree4fa2d36258e85b6c4e8a9df3e3ebb4c86f0cebd7 /meta/lib/oeqa/runtime/kernelmodule.py
parent33274012640be85ea2d1349cd7e3e43e9d8f1ca7 (diff)
downloadopenembedded-core-contrib-b8f704285f2e00b30f5007217b8575e0820953f1.tar.gz
oeqa/runtime: Fix setUp and tearDown methods
Currently some of the runtime test overwrites the setUp and tearDown methods provided by oeRuntimeTest, this will avoid some checks required when running the test suit. This patch changes the setUp and tearDown methods for their local counterparts, so when these tests are called, it will run the parent setUp and tearDown and also the local ones. [YOCTO #8465] (From OE-Core rev: 13282223b07787a92c251f89251e8a49a0e4e3eb) Signed-off-by: Mariano Lopez <mariano.lopez@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/lib/oeqa/runtime/kernelmodule.py')
-rw-r--r--meta/lib/oeqa/runtime/kernelmodule.py4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta/lib/oeqa/runtime/kernelmodule.py b/meta/lib/oeqa/runtime/kernelmodule.py
index 2e81720327..38ca184540 100644
--- a/meta/lib/oeqa/runtime/kernelmodule.py
+++ b/meta/lib/oeqa/runtime/kernelmodule.py
@@ -10,7 +10,7 @@ def setUpModule():
class KernelModuleTest(oeRuntimeTest):
- def setUp(self):
+ def setUpLocal(self):
self.target.copy_to(os.path.join(oeRuntimeTest.tc.filesdir, "hellomod.c"), "/tmp/hellomod.c")
self.target.copy_to(os.path.join(oeRuntimeTest.tc.filesdir, "hellomod_makefile"), "/tmp/Makefile")
@@ -30,5 +30,5 @@ class KernelModuleTest(oeRuntimeTest):
(status, output) = self.target.run(cmd, 900)
self.assertEqual(status, 0, msg="\n".join([cmd, output]))
- def tearDown(self):
+ def tearDownLocal(self):
self.target.run('rm -f /tmp/Makefile /tmp/hellomod.c')