aboutsummaryrefslogtreecommitdiffstats
path: root/meta/lib/oe/recipeutils.py
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2015-11-19 14:15:55 +1300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-12-01 21:30:55 +0000
commita4c6af737811adb2bca87e3896f8710738dd255e (patch)
tree3eff1e84956c60702660967d471ce5356e2892d7 /meta/lib/oe/recipeutils.py
parenta30b407474d4eb6620f1ec549b54187ebbaff008 (diff)
downloadopenembedded-core-contrib-a4c6af737811adb2bca87e3896f8710738dd255e.tar.gz
lib/oe/recipeutils: check in validate_pn() for names instead of filenames
Ensure that the user specifies just the name portion instead of a file name with extension. (We can't just look for . since there are recipe names such as "glib-2.0" that legitimately contain .). Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/lib/oe/recipeutils.py')
-rw-r--r--meta/lib/oe/recipeutils.py2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta/lib/oe/recipeutils.py b/meta/lib/oe/recipeutils.py
index 119a68821b..8918facb5b 100644
--- a/meta/lib/oe/recipeutils.py
+++ b/meta/lib/oe/recipeutils.py
@@ -398,6 +398,8 @@ def validate_pn(pn):
return 'Recipe name "%s" is invalid: is a reserved keyword' % pn
elif pn.startswith('pn-'):
return 'Recipe name "%s" is invalid: names starting with "pn-" are reserved' % pn
+ elif pn.endswith(('.bb', '.bbappend', '.bbclass', '.inc', '.conf')):
+ return 'Recipe name "%s" is invalid: should be just a name, not a file name' % pn
return ''