aboutsummaryrefslogtreecommitdiffstats
path: root/meta/conf
diff options
context:
space:
mode:
authorPatrick Ohly <patrick.ohly@intel.com>2017-06-09 15:04:03 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-06-12 15:04:12 +0100
commit3b3ae91a22d6f685e804df4f32cdeebe1bd6bd88 (patch)
treecfabf9d8949350bab93854423994a2c9dc866e61 /meta/conf
parent9c91df324dfe58273f5a1d1d33dba1d34a180db7 (diff)
downloadopenembedded-core-contrib-3b3ae91a22d6f685e804df4f32cdeebe1bd6bd88.tar.gz
bitbake.conf: DISTRO_FEATURES as overrides
As discussed in "[Openembedded-architecture] Yocto Compatible 2.0 + signature changes", changes in .bbappend must depend on some explicit configuration change, typically selecting a distro feature. For _append and _remove, adding an override that is set only when the corresponding entry is in DISTRO_FEATURES achieves that: In local.conf: DISTRO_FEATURES_append = " my-distro-feature" In layer.conf: DISTRO_FEATURES_OVERRIDES += "my-distro-feature" In a .bbappend: do_install_append_df-my-distro-feature () { ... } The subset of DISTRO_FEATURES that are made available as overrides must be configured explicitly because using them this way should be a conscious decision. Signed-off-by: Patrick Ohly <patrick.ohly@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/conf')
-rw-r--r--meta/conf/bitbake.conf17
1 files changed, 16 insertions, 1 deletions
diff --git a/meta/conf/bitbake.conf b/meta/conf/bitbake.conf
index caae6a012b..bc438cca82 100644
--- a/meta/conf/bitbake.conf
+++ b/meta/conf/bitbake.conf
@@ -713,7 +713,7 @@ DISTRO_NAME ??= "OpenEmbedded"
#
# This works for functions as well, they are really just environment variables.
# Default OVERRIDES to make compilation fail fast in case of build system misconfiguration.
-OVERRIDES = "${TARGET_OS}:${TRANSLATED_TARGET_ARCH}:build-${BUILD_OS}:pn-${PN}:${MACHINEOVERRIDES}:${DISTROOVERRIDES}:${CLASSOVERRIDE}:forcevariable"
+OVERRIDES = "${TARGET_OS}:${TRANSLATED_TARGET_ARCH}:build-${BUILD_OS}:pn-${PN}:${MACHINEOVERRIDES}:${DISTROOVERRIDES}${DISTROFEATURESOVERRIDES}:${CLASSOVERRIDE}:forcevariable"
OVERRIDES[vardepsexclude] = "MACHINEOVERRIDES"
CLASSOVERRIDE ?= "class-target"
DISTROOVERRIDES ?= "${@d.getVar('DISTRO') or ''}"
@@ -722,6 +722,21 @@ MACHINEOVERRIDES[vardepsexclude] = "MACHINE"
FILESOVERRIDES = "${TRANSLATED_TARGET_ARCH}:${MACHINEOVERRIDES}:${DISTROOVERRIDES}"
+# Turns certain DISTRO_FEATURES into overrides of the same name
+# or (optionally) some other name. Ensures that these special
+# distro features remain set also for native and nativesdk
+# recipes, so that these overrides can also be used there.
+#
+# Beware that this part of OVERRIDES changes during parsing, so usage
+# of these overrides should be limited to .bb and .bbappend files,
+# because then DISTRO_FEATURES is final.
+DISTRO_FEATURES_OVERRIDES ??= ""
+DISTRO_FEATURES_OVERRIDES[doc] = "A space-separated list of <feature> entries. \
+Each entry is added to OVERRIDES as df-<feature> if <feature> is in DISTRO_FEATURES."
+DISTRO_FEATURES_FILTER_NATIVE_append = " ${DISTRO_FEATURES_OVERRIDES}"
+DISTRO_FEATURES_FILTER_NATIVESDK_append = " ${DISTRO_FEATURES_OVERRIDES}"
+DISTROFEATURESOVERRIDES = "${@ ''.join([':df-' + x for x in (set(d.getVar('DISTRO_FEATURES_OVERRIDES').split()) & set((d.getVar('DISTRO_FEATURES') or '').split()))]) }"
+
##################################################################
# Include the rest of the config files.
##################################################################