aboutsummaryrefslogtreecommitdiffstats
path: root/meta/conf/layer.conf
diff options
context:
space:
mode:
authorChristopher Larson <chris_larson@mentor.com>2013-03-18 18:55:07 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-03-19 11:52:21 +0000
commit643ac87145eba5dc105377041bc3deb163b62926 (patch)
tree0266f969d5e9021d7d86d71d5c9a97dad42ef073 /meta/conf/layer.conf
parent5704dfa690a625abcface432cf5f9c9bc3ee8abd (diff)
downloadopenembedded-core-contrib-643ac87145eba5dc105377041bc3deb163b62926.tar.gz
layer.conf: avoid unnecessary early expansion with :=
bitbake handles immediate expansions of LAYERDIR for us automatically. Signed-off-by: Christopher Larson <chris_larson@mentor.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/conf/layer.conf')
-rw-r--r--meta/conf/layer.conf6
1 files changed, 3 insertions, 3 deletions
diff --git a/meta/conf/layer.conf b/meta/conf/layer.conf
index 6e5cd0cf8d..81f1071a91 100644
--- a/meta/conf/layer.conf
+++ b/meta/conf/layer.conf
@@ -4,7 +4,7 @@ BBPATH .= ":${LAYERDIR}"
BBFILES += "${LAYERDIR}/recipes-*/*/*.bb"
BBFILE_COLLECTIONS += "core"
-BBFILE_PATTERN_core := "^${LAYERDIR}/"
+BBFILE_PATTERN_core = "^${LAYERDIR}/"
BBFILE_PRIORITY_core = "5"
# This should only be incremented on significant changes that will
@@ -12,10 +12,10 @@ BBFILE_PRIORITY_core = "5"
LAYERVERSION_core = "1"
# Set a variable to get to the top of the metadata location
-COREBASE := '${@os.path.normpath("${LAYERDIR}/../")}'
+COREBASE = '${@os.path.normpath("${LAYERDIR}/../")}'
# Set path to qemu image tests included in this layer
-QEMUIMAGETESTS := "${COREBASE}/scripts/qemuimage-tests"
+QEMUIMAGETESTS = "${COREBASE}/scripts/qemuimage-tests"
SIGGEN_EXCLUDERECIPES_ABISAFE += " \
sysvinit-inittab \