aboutsummaryrefslogtreecommitdiffstats
path: root/meta/classes
diff options
context:
space:
mode:
authorSamuel Stirtzel <s.stirtzel@googlemail.com>2012-10-18 09:32:47 +0200
committerMarcin Juszkiewicz <marcin.juszkiewicz@linaro.org>2012-11-29 12:00:24 +0100
commit5ec42c80bc32f7e7a247cc16d72074e4789026ab (patch)
tree6a508ee4e901ef4a481c2e4261f9eaebce3ab8a0 /meta/classes
parent83aa3c7d63dd2018f0801f2d98e2d74b8bce330f (diff)
downloadopenembedded-core-contrib-5ec42c80bc32f7e7a247cc16d72074e4789026ab.tar.gz
gtk-immodules-cache: Add initial class to update gtk inputmethod module cache
This is used by: openembedded-core/meta/recipes-sato/matchbox-keyboard/matchbox-keyboard_git.bb meta-openembedded/meta-oe/recipes-support/maliit/maliit-framework_git.bb Signed-off-by: Samuel Stirtzel <s.stirtzel@googlemail.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/classes')
-rw-r--r--meta/classes/gtk-immodules-cache.bbclass55
1 files changed, 55 insertions, 0 deletions
diff --git a/meta/classes/gtk-immodules-cache.bbclass b/meta/classes/gtk-immodules-cache.bbclass
new file mode 100644
index 0000000000..515d28b5b4
--- /dev/null
+++ b/meta/classes/gtk-immodules-cache.bbclass
@@ -0,0 +1,55 @@
+# This class will update the inputmethod module cache for virtual keyboards
+#
+# Usage: Set GTKIMMODULES_PACKAGES to the packages that needs to update the inputmethod modules
+
+gtk_immodule_cache_postinst() {
+if [ "x$D" != "x" ]; then
+ exit 1
+fi
+if [ ! -z `which gtk-query-immodules-2.0` ]; then
+ gtk-query-immodules-2.0 > /etc/gtk-2.0/gtk.immodules
+fi
+if [ ! -z `which gtk-query-immodules-3.0` ]; then
+ gtk-query-immodules-3.0 > /etc/gtk-3.0/gtk.immodules
+fi
+}
+
+gtk_immodule_cache_postrm() {
+if [ "x$D" != "x" ]; then
+ exit 1
+fi
+if [ ! -z `which gtk-query-immodules-2.0` ]; then
+ gtk-query-immodules-2.0 > /etc/gtk-2.0/gtk.immodules
+fi
+if [ ! -z `which gtk-query-immodules-3.0` ]; then
+ gtk-query-immodules-3.0 > /etc/gtk-3.0/gtk.immodules
+fi
+}
+
+python populate_packages_append () {
+ gtkimmodules_pkgs = d.getVar('GTKIMMODULES_PACKAGES', True).split()
+
+ for pkg in gtkimmodules_pkgs:
+ bb.note("adding gtk-immodule-cache postinst and postrm scripts to %s" % pkg)
+
+ postinst = d.getVar('pkg_postinst_%s' % pkg, True) or d.getVar('pkg_postinst', True)
+ if not postinst:
+ postinst = '#!/bin/sh\n'
+ postinst += d.getVar('gtk_immodule_cache_postinst', True)
+ d.setVar('pkg_postinst_%s' % pkg, postinst)
+
+ postrm = d.getVar('pkg_postrm_%s' % pkg, True) or d.getVar('pkg_postrm', True)
+ if not postrm:
+ postrm = '#!/bin/sh\n'
+ postrm += d.getVar('gtk_immodule_cache_postrm', True)
+ d.setVar('pkg_postrm_%s' % pkg, postrm)
+}
+
+python __anonymous() {
+ if not bb.data.inherits_class('native', d) and not bb.data.inherits_class('cross', d):
+ gtkimmodules_check = d.getVar('GTKIMMODULES_PACKAGES')
+ if not gtkimmodules_check:
+ bb_filename = d.getVar('FILE')
+ raise bb.build.FuncFailed, "\n\n\nERROR: %s inherits gtk-immodule-cache but doesn't set GTKIMMODULES_PACKAGE" % bb_filename
+}
+